DragonFly users List (threaded) for 2005-11
Re: RC variable naming
:I was thinking about deprecating the use of X_enable by effectively
:turning the helper function into a NOP after setting a special internal
:variable. That variable would be processed by load_rc_config to load the
:value of the old variable if necessary (read: if present). That would be
:active for 1.4 (maybe as option RCNG_OLDNAME?), so that users updating
:from 1.2 are not hurt too badly.
Lets not do anything for 1.4. We can figure out what to do after
the release. It seems to me that we will probably want to go
the way of NetBSD to make pkgsrc integration easier.
Doing it now makes the migration a bit less painful, since (most likely)
lesser users are affected. The RCNG_OLDNAME is just an idea, I'd try to
make it fully transparent for the initial conversion (with the exception
of warning about deprecated usage). The changes to be made are localised
to /etc/rc.conf and /etc/rc.conf.d/*.
I am all for this change. This would give us a transition period until
the next release. Gets my vote (I think some of us discussed this
already, but I can't remember who and where). +1
Serve - BSD +++ RENT this banner advert +++ ASCII Ribbon /"\
Work - Mac +++ space for low €€€ NOW!1 +++ Campaign \ /
Party Enjoy Relax | http://dragonflybsd.org Against HTML \
Dude 2c 2 the max ! http://golden-apple.biz Mail + News / \