DragonFly users List (threaded) for 2005-11
Re: RC variable naming
:since using pkgsrc puts us a bit nearer to NetBSD with regard to RCng,
:what is the current position on the naming of the variables? FreeBSD
:changed the activation variable for X to X_enable, NetBSD and pkgsrc
:still use just plain X.
:I was thinking about deprecating the use of X_enable by effectively
:turning the helper function into a NOP after setting a special internal
:variable. That variable would be processed by load_rc_config to load the
:value of the old variable if necessary (read: if present). That would be
:active for 1.4 (maybe as option RCNG_OLDNAME?), so that users updating
:from 1.2 are not hurt too badly.
Lets not do anything for 1.4. We can figure out what to do after
the release. It seems to me that we will probably want to go
the way of NetBSD to make pkgsrc integration easier.