DragonFly submit List (threaded) for 2006-07
rc.d standardization patch
There is quite a bit of non standardness in the rc.d system and this
aims to get us a little closer to the way NetBSD does things and
rename start_vinum -> vinum, enable_quotas -> quotas
remove all instances of _enable
respect configs that use old names with _enable but output a warning
saying _enable is deprecated.
kerberos5, kadmind, kpasswd had the program path in a nonstandard
variable added _program variable which seems to be the standard.
These 3 had _server in the name i removed that as well to make
translation between the old config and new config possible.
here is the diff: http://www.uberstyle.net/~kevin/rcenable.diff
If there are any suggestions for renaming and cleaning up other rcvar
names let me know and ill add them in to this patch.
Kevin L. Kane
kevin.kane at gmail.com