DragonFly On-Line Manual Pages
VIRTIO_SCSI(4) DragonFly Kernel Interfaces Manual VIRTIO_SCSI(4)
virtio_scsi -- VirtIO SCSI driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The virtio_scsi device driver provides support for VirtIO SCSI devices.
Tunables can be set at the loader(8) prompt before booting the kernel or
stored in loader.conf(5).
In the initial QEMU release with VirtIO SCSI support, in-flight
operations were not aborted when stopping the device, rendering
bus reset ineffective. This tunable disables attempts to issue
reset bus commands. The default value is 1.
To enable debugging prints from the virtio_scsi driver, set the
variable, where X is the adapter number, either in loader.conf(5) or via
sysctl(8). The following bits have the described effects:
0x01 Enable informational prints.
0x02 Enable prints for driver errors.
0x04 Enable tracing prints.
The virtio_scsi driver was written by Bryan Venteicher
<bryanv@FreeBSD.org>. It first appeared in FreeBSD 10.0.
DragonFly 5.3 July 30, 2017 DragonFly 5.3