DragonFly On-Line Manual Pages
UEFI(8) DragonFly System Manager's Manual UEFI(8)
UEFI - Unified Extensible Firmware Interface bootstrapping procedures
The UEFI Unified Extensible Firmware Interface provides boot- and run-
time services to operating systems. UEFI is a replacement for the legacy
BIOS on the i386 and amd64 CPU architectures, and is also used on arm64
The UEFI boot process loads system bootstrap code located in an EFI
System Partition (ESP). The ESP is a GPT or MBR partition with a
specific identifier that contains an msdos(5) FAT file system with a
specified file hierarchy.
Partition Scheme ESP Identifier
The UEFI boot process proceeds as follows:
1. UEFI firmware runs at power up and searches for an OS loader
in the EFI system partition. The path to the loader may be
set by an EFI environment variable. If not set, the default
is /EFI/BOOT/BOOTX64.EFI. The default UEFI boot configuration
for DragonFly installs boot1.efi as /EFI/BOOT/BOOTX64.EFI.
2. boot1.efi reads boot configuration from /boot.config or
/boot/config. Unlike other first-stage boot loaders,
boot1.efi passes the configuration to the next stage boot
loader and does not itself act on the contents of the file.
3. boot1.efi searches partitions of type `DragonFly UFS1' and the
first disklabel64(5) partition in GPT partitions of type
`DragonFly Label64' for loader.efi. The search begins with
partitions on the device from which boot1.efi was loaded, and
continues with other available partitions. boot1.efi then
loads and executes loader.efi.
4. loader.efi loads and boots the kernel, as described in
First stage UEFI bootstrap
Final stage bootstrap
typical non-default kernel (optional)
efivar(3), disklabel64(5), msdos(5), boot(8), efibootmgr(8), efidp(8),
efisetup(8), efivar(8), uefisign(8)
UEFI boot support first appeared in FreeBSD 10.1 and was brought into
UEFI boot support was developed by Benno Rice <benno@FreeBSD.org>, Ed
Maste <emaste@FreeBSD.org>, and Nathan Whitehorn
<nwhitehorn@FreeBSD.org>. The FreeBSD Foundation sponsored portions of
EFI environment variables are not supported by loader(8) or the kernel.
DragonFly 5.9-DEVELOPMENT June 13, 2020 DragonFly 5.9-DEVELOPMENT