DragonFly On-Line Manual Pages
MRSAS(4) DragonFly Kernel Interfaces Manual MRSAS(4)
mrsas -- LSI MegaRAID 6Gb/s and 12Gb/s SAS+SATA RAID controller driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The mrsas driver will detect LSI's next generation (6Gb/s and 12Gb/s) PCI
Express SAS/SATA RAID controllers. See the HARDWARE section for the
supported devices list. A disk (virtual disk/physical disk) attached to
the mrsas driver will be visible to the user through camcontrol(8) as
/dev/da? device nodes. A simple management interface is also provided on
a per-controller basis via the /dev/mrsas? device node.
The mrsas name is derived from the phrase "MegaRAID SAS HBA", which is
substantially different than the old "MegaRAID" Driver mfi(4) which does
not connect targets to the cam(4) layer and thus requires a new driver
which attaches targets to the cam(4) layer. Older MegaRAID controllers
are supported by mfi(4) and amr(4) and will not work with mrsas, but both
the mfi(4) and mrsas drivers can detect and manage the LSI MegaRAID SAS
2208/2308/3008/3108 series of controllers.
The mrsas driver supports the following hardware:
[ Thunderbolt 6Gb/s MR controller ]
o LSI MegaRAID SAS 9265
o LSI MegaRAID SAS 9266
o LSI MegaRAID SAS 9267
o LSI MegaRAID SAS 9270
o LSI MegaRAID SAS 9271
o LSI MegaRAID SAS 9272
o LSI MegaRAID SAS 9285
o LSI MegaRAID SAS 9286
o DELL PERC H810
o DELL PERC H710/P
[ Invader/Fury 12Gb/s MR controller ]
o LSI MegaRAID SAS 9380
o LSI MegaRAID SAS 9361
o LSI MegaRAID SAS 9341
o DELL PERC H830
o DELL PERC H730/P
o DELL PERC H330
A tunable is provided to adjust the mrsas driver's behaviour when
attaching to a card. By default, the driver will attach to all known
cards with high probe priority. For ``Thunderbolt'' series cards this
behavior can be changed to attaching via the mfi(4) driver by setting the
following tunable value in loader.conf(5):
By default, the driver will use MSI if it is supported. This behavior
can be turned off by setting the following tunable value in
To disable Online Controller Reset(OCR) for a specific mrsas driver
instance, set the following tunable value in loader.conf(5):
where X is the adapter number.
To change the I/O timeout value for a specific mrsas driver instance, set
the following tunable value in loader.conf(5):
where NNNNNN is the timeout value in milli-seconds.
To change the firmware fault check timer value for a specific mrsas
driver instance, set the following tunable value in loader.conf(5):
where NN is the fault check delay value in seconds.
The current number of active I/O commands is shown in the
dev.mrsas.X.fw_outstanding sysctl(8) variable.
To enable debugging prints from the mrsas driver, set the
dev.mrsas.X.debug_level variable, where X is the adapter number, either
in loader.conf(5) or via sysctl(8). The following bits have the
0x01 Enable informational prints.
0x02 Enable tracing prints.
0x04 Enable prints for driver faults.
0x08 Enable prints for OCR and I/O timeout.
0x10 Enable prints for AEN events.
/dev/da? array/logical disk interface
/dev/mrsas? management interface
amr(4), cam(4), mfi(4), pci(4), device.hints(5), camcontrol(8)
The mrsas driver first appeared in FreeBSD 10.1 and was ported to
mfi Driver: mfi(4) is the old FreeBSD driver which started with support
for Gen-1 Controllers and was extended to support up to MR-Fusion (Device
ID = 0x005B, 0x005D, 0x005F).
mrsas Driver: mrsas is the new driver reworked by LSI which supports
Thunderbolt and onward products. The SAS+SATA RAID controller with
device id 0x005b is referred to as the Thunderbolt controller throughout
this man page.
cam aware HBA drivers: FreeBSD has a cam(4) layer which attaches storage
devices and provides a common access mechanism to storage controllers and
attached devices. The mrsas driver is cam(4) aware and devices
associated with mrsas can be seen using camcontrol(8). The mfi(4) driver
does not understand the cam(4) layer and it directly associates storage
disks to the block layer.
Thunderbolt Controller: This is the 6Gb/s MegaRAID HBA card which has
device id 0x005B.
Invader Controller: This is 12Gb/s MegaRAID HBA card which has device id
Fury Controller: This is the 12Gb/s MegaRAID HBA card which has device id
The mrsas driver and this manual page were written by Kashyap Desai
<Kashyap.Desai@lsi.com>. It was ported to DragonFly by
Sascha Wildner <email@example.com>.
The driver does not support alias for device name (it is required when
the user switches between two drivers and does not want to edit
/etc/fstab manually for /dev/mfid? device nodes). It is recommended to
use the approriate device nodes in /dev/serno instead. They should be
available for all controllers supported by mrsas.
The mrsas driver exposes devices as /dev/da?, whereas mfi(4) exposes
devices as /dev/mfid?.
mrsas will not work with mfiutil(8).
DragonFly 4.7 November 28, 2014 DragonFly 4.7