DragonFly On-Line Manual Pages
MPS(4) DragonFly Kernel Interfaces Manual MPS(4)
mps - LSI Fusion-MPT 2 Serial Attached SCSI driver
To compile this driver into your kernel, place the following lines in
your kernel configuration file:
Or, to load the driver as a module at boot, place the following line in
The mps driver provides support for LSI Logic Fusion-MPT 2 SAS
controllers and WarpDrive solid state storage cards.
The mps driver supports the following hardware:
* LSI Logic SAS2004 (4 Port SAS)
* LSI Logic SAS2008 (8 Port SAS)
* LSI Logic SAS2108 (8 Port SAS)
* LSI Logic SAS2116 (16 Port SAS)
* LSI Logic SAS2208 (8 Port SAS)
* LSI Logic SAS2308 (8 Port SAS)
* LSI Logic SSS6200 Solid State Storage
* Intel Integrated RAID Module RMS25JB040
* Intel Integrated RAID Module RMS25JB080
* Intel Integrated RAID Module RMS25KB040
* Intel Integrated RAID Module RMS25KB080
To disable MSI interrupts for all mps driver instances, set the following
tunable value in loader.conf(5):
To set the maximum number of DMA chains allocated for all adapters, set
the following variable in loader.conf(5):
To set the maximum number of DMA chains allocated for a specific adapter,
set the following variable in loader.conf(5):
This variable may also be viewed via sysctl(8) to see the maximum set for
a given adapter.
The current number of free chain frames may be seen via the
hw.mpsX.chain_free sysctl(8) variable.
The lowest number of free chain frames may be seen via the
hw.mpsX.chain_free_lowwater sysctl(8) variable.
The current number of active I/O commands is shown in the
hw.mpsX.io_cmds_active sysctl(8) variable.
The maximum number of active I/O command seen since boot is shown in the
hw.mpsX.io_cmds_highwater sysctl(8) variable.
To enable debugging prints from the mps driver, set the
variable, where X is the adapter number, either in loader.conf(5) or via
sysctl(8). The following bits have the described effects:
0x01 Enable informational prints.
0x02 Enable tracing prints.
0x04 Enable prints for driver faults.
0x08 Enable prints for controller events.
cd(4), ch(4), da(4), mpr(4), mpt(4), pci(4), sa(4), scsi(4), targ(4),
The mps driver first appeared in FreeBSD 9.0.
The mps driver was originally written by Scott Long <scottl@FreeBSD.org>.
It has been improved and tested by LSI Logic Corporation. This man page
was written by Ken Merry <ken@FreeBSD.org>.
This driver has a couple of known shortcomings:
* No userland utility available (e.g. mptutil(8)).
* The driver probes devices sequentially. If your system has a large
number of devices, the probe will take a while.
DragonFly 5.9-DEVELOPMENT April 24, 2018 DragonFly 5.9-DEVELOPMENT