DragonFly On-Line Manual Pages
KCOLLECT(8) DragonFly System Manager's Manual KCOLLECT(8)
kcollect -- extract kernel-collected statistics
kcollect [-o fields] [-b file] [-d file] [-r file] [-f] [-l] [-g] [-s]
[-t time] [-G] [-W width] [-H height] [-w plotfile]
The kcollect utility extracts regularly collected statistics accumulated
by the kernel. The kernel typically keeps around 23 hours worth of sta-
tistics. If no specific output option is specified, a human-readable
text dump of the accumulated statistics will be output starting with the
most recent collection and then going back in time.
The following options are available:
Indicate which fields to extract. If not specified, all avail-
able fields are extracted. Unknown fields are ignored. Note
that not all commands will filter based on the field list.
You may specify space or comma-separated fieldnames. Whitespace
is ignored. Use the -l option to get a list of available fields.
Dump the data to a dbm database, creating the database if neces-
sary. Data is indexed by gmt time, which will be calculated from
the ticks. Duplicate tuples are ignored. The database will
retain data from prior runs.
Load the data from a dbm database instead of loading the active
data from the current machine.
This will overwrite headers stored in the specified dbm database
with the in-memory headers. This can be used to renormalize
saved historical dbm files when machine specs change, or if the
dbm is somehow missing the header fields.
-g Generate gnuplot output for the data.
-s Smooth plot output (only applicable to gnuplot). This may make
it more readable. Data is smoothed using an exponential average
over 10 samples (~100 seconds).
Specify the number of seconds worth of recent data to extract.
The 'm', 'h', and 'd' suffixes can be used to specify the value
in minutes, hours, or days.
-x Generate gnuplot output for the data and pipe it to gnuplot for
display to X11.
-l List all available fields and the field format
-f Dump available output then enter a 60-second sleep/collection
loop to incrementally collect and output more data. If out-
putting to gnuplot, the plot will be updated regularly. However,
please note that this is fairly expensive since the plot data has
to be completely re-sent to gnuplot on each update.
Generate gnuplot output to a .png or .jpg file, depending on the
extension of the filename you supply.
-G Timestamps for text output will be in GMT instead of localtime.
Set the width and height of the output plot for the plotfile or
for X. The default is 512x512.
A kcollect utility appeared in DragonFly 4.9.
DragonFly 5.5 July 29, 2017 DragonFly 5.5