DragonFly On-Line Manual Pages
INITRD(7) DragonFly Miscellaneous Information Manual INITRD(7)
initrd -- initial ramdisk image as early userland
The initrd is a small initial ramdisk image that packs a minimal init(8),
basic rc(8) scripts, and many other statically linked tools, such as var-
ious mount(8) utilities, lvm(8), cryptsetup(8), tcplay(8), as well as
some networking tools. The initrd is a nice early userland and is
required to help mount the root partition residing on an encrypted device
The statically linked tools are known as the ``rescue tools'' and shipped
at /rescue. The inclusion of such rescue tools makes initrd can provide
with a powerful rescue environment to fix severe problems, e.g., the root
partition cannot be mounted. Users can also choose to boot into the res-
cue mode from the bootloader menu.
The initrd is a md(4) image formatted with the UFS(5) filesystem. It is
created by the ``initrd'' target of the build(7) framework, and is com-
pressed and installed at /boot/kernel/initrd.img.gz. The following con-
figurations should be added to /boot/loader.conf to make use of the
Then, the ``vfs.root.realroot'' kernel environment variable can be con-
figured to specify how to mount the real root partition. Its general
Currently, the supported types of real root partition are: local, crypt,
and tcplay. The local type allows to mount any local filesystem that
does not require any special setup apart from the initial discovery and
calling the mount(8) program. The general format is as follows:
The crypt and tcplay types allow to mount volumes supported by
cryptsetup(8) and tcplay(8), respectively. The device will be set up
after asking the user for the key, and this volume will then be mounted
as the root. The general formats are as follows:
/boot/kernel/initrd.img.gz Location of the compressed initrd image.
md(4), loader.conf(5), build(7), cryptsetup(8), lvm(8), tcplay(8)
The initrd manual page first appeared in DragonFly 5.3.
The initrd manual page was written by Aaron LI <email@example.com>.
The initrd image occupies about 10-15 MB wired memory and cannot be freed
after chrooting to the real root partition.
DragonFly 5.3 June 2, 2018 DragonFly 5.3