DragonFly On-Line Manual Pages
DSCHED(4) DragonFly Kernel Interfaces Manual DSCHED(4)
dsched -- kernel disk scheduler framework
The dsched framework implements a disk scheduler framework that can be
used to switch disk scheduling policies at runtime for each disk in the
system. The dsched framework and the policies for each disk can be man-
aged via loader(8) tunables and via sysctl(8) variables.
Tunables can be set at the loader(8) prompt before booting the kernel or
stored in loader.conf(5).
dsched.policy.default This tunable sets the default policy used for
every device that has no policy specified via any
of the other tunables.
dsched.policy.da0 This tunable sets the dsched policy for the disk
da0. The default value is 0.
dsched.policy.da This tunable sets the dsched policy for all disks
created by the driver da(4).
dsched.debug set the debug-level, 0 means no debugging, 5 for
dsched.policy.default shows and sets the current default dsched policy.
dsched.policy.da0 shows and sets the current policy for the disk
dsched.policy.SN39A39 shows and sets the current policy for the disk
with serial number SN39A39.
The following are informative only:
dsched.policies shows all available dsched policies, separated by
dsched_bfq(4), loader.conf(5), sysctl.conf(5), dsched(9)
The dsched framework first appeared in DragonFly 2.5.
The dsched framework was written by Alex Hornung.
DragonFly 4.3 August 16, 2010 DragonFly 4.3