DragonFly On-Line Manual Pages
DHCP(8) DragonFly System Manager's Manual DHCP(8)
dhcp -- configuring DragonFly for DHCP
The Dynamic Host Configuration Protocol (DHCP) allows hosts on a TCP/IP
network to configure one or more network interfaces based on information
collected from a DHCP server in response to a DHCP request. This
mechanism is often used, for example, by cable modem and DSL network
providers to simplify network configurations for their clients/customers.
Information typically contained within a DHCP response includes an IP
address for the interface, subnet mask, broadcast address, router
(gateway) listing, domain name server listing, and the interface's MTU.
To set up DragonFly as a DHCP client:
1. For each interface that is to be configured via DHCP, add
``DHCP'' to the ifconfig_<interface> variable in /etc/rc.conf.
See rc.conf(5) for more information on the format of this
The /etc/network.subr script reads each of these variables at
boot-time and runs the DHCP client, e.g., dhclient(8) or
dhcpcd(8), for each interface that is to be configured via
2. [Optional] To tweak settings, edit /etc/dhclient.conf (if
dhcp_client="dhclient") or /etc/dhcpcd.conf (if
dhcp_client="dhcpcd"). See dhclient.conf(5) and
dhcpcd.conf(5) for details.
To set up DragonFly as a DHCP server:
1. Install dhcpd(8) (available in dports(7)).
2. Edit /usr/local/etc/dhcp/dhcpd.conf. See dhcpd.conf(5) and
dhcpd(8) for details.
3. Edit /etc/rc.conf and set dhcpd_flags="". This will cause
DragonFly to start the dhcpd(8) daemon at boot-time and listen
for DHCP requests on the local network. To start it manually,
execute the following command:
# /usr/local/sbin/dhcpd [netif1 netif2 ...]
The DHCP client and server use the Berkeley Packet Filter (BPF). Ensure
the kernel has been compiled with BPF support and at least one /dev/bpf*
file exists per broadcast network interface that is attached to the
system. This is almost always the case and should only be considered if
all other troubleshooting options have failed.
See dhcpd(8) for information on other available options. Note, however,
that most of the flags are useful only for debugging purposes.
/etc/rc.conf configuration file where DHCP client
configuration is set for individual interfaces
and dhcpd_flags must be set
/etc/dhclient.conf DHCP client configuration file for dhclient(8)
/etc/dhcpcd.conf DHCP client configuration file for dhcpcd(8)
DHCP server configuration file
dhclient.conf(5), dhcpcd.conf(5), dhcpd.conf(5) (net/isc-dhcp44-server),
dhclient(8), dhcpcd(8), dhcpd(8) (net/isc-dhcp44-server), dhcrelay(8)
DragonFly 5.3 October 25, 2018 DragonFly 5.3