DragonFly On-Line Manual Pages
ARCMSR(4) DragonFly Kernel Interfaces Manual ARCMSR(4)
arcmsr -- Areca RAID Controller driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The arcmsr driver provides support for the Areca ARC-11xx, ARC-12xx,
ARC-13xx, ARC-16xx and ARC-18xx series of SAS and SATA RAID controllers.
These controllers feature RAID-0, 1, 3, 5, 6, and 10 and JBOD
acceleration for up to 16 SATA drives. RAID level and stripe level
migration, online capacity expansion, hot insertion/removal, automatic
failover and rebuild, and SMART are also supported. Access to the arrays
is provided via the SCSI CAM /dev/da? device nodes. A management
interface is also present via the /dev/arcmsr? device node.
By default, the driver will use MSI if it is supported. This
behavior can be turned off by setting this tunable to 0.
The arcmsr driver supports the following cards:
/dev/da? Array block device
/dev/arcmsr? Management interface
The arcmsr driver first appeared in FreeBSD 5.4.
The driver was written by Erich Chen <firstname.lastname@example.org>.
The driver has been tested on i386 and amd64. It likely requires
additional work to function on big-endian architectures.
DragonFly 4.9 November 6, 2017 DragonFly 4.9