DragonFly kernel List (threaded) for 2007-01
Re: machine/platform separation
Matthew Dillon wrote:
Part of the problem is that I only separated the code into two
physical pieces (cpu and machine architectures) when I should have
separated it into three (cpu, machine, and platform). At the time I
felt three was too many. I even created three built-in MAKE variables,
I just named them badly and didn't go far enough.
where is the difference between platform and machine?
can't we use:
cpu == arch (== machine?):
and have everything covered?
does it *have* to be a different name for platform and cpu? i mean, that's two different namespaces, i do not see any harm using i386 as a platform name. my goal is to keep things as easy as possible. a cross-build should just require TARGET_ARCH=amd64, or fwiw, TARGET_PLATFORM=vkernel. but the nomenclature should be sensible and follow POLA.
Serve - BSD +++ RENT this banner advert +++ ASCII Ribbon /"\
Work - Mac +++ space for low €€€ NOW!1 +++ Campaign \ /
Party Enjoy Relax | http://dragonflybsd.org Against HTML \
Dude 2c 2 the max ! http://golden-apple.biz Mail + News / \