DragonFly BSD
DragonFly bugs List (threaded) for 2004-08
[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]

Re: i installed portupgrade but is canš't upgrade any packlage beacuse conflict with packages


From: "CrAsH" <danielolsson14@xxxxxxxxxxx>
Date: Sun, 15 Aug 2004 16:44:51 +0200

well i tried portversion | grep '<' and after that portupgrade -a seems to
work is showing dfly installer but is continue to upgrade the other packages
thx




"Sarunas Vancevicius" <vsarunas@xxxxxxxxxx> skrev i meddelandet
news:20040815153704.GA3244@xxxxxxxxxxxxxxxxxxx
> On 16:17, Sun 15 Aug 04, CrAsH wrote:
> >
> > Here is the errors
> >
> > su-2.05b# portupgrade -a
> > [Updating the pkgdb <format:bdb1_btree> in /var/db/pkg ... - 22 packages
> > found (-0 +2) .. done]
> > cd: can't cd to /usr/ports/sysutils/dfuibe_installer
> > cd: can't cd to /usr/ports/sysutils/dfuife_cgi
> > cd: can't cd to /usr/ports/sysutils/dfuife_curses
> > cd: can't cd to /usr/ports/sysutils/libdfui
> > cd: can't cd to /usr/ports/www/thttpd-notimeout
> > ** Port directory not found: sysutils/dfuibe_installer
> > ** Port directory not found: sysutils/dfuife_cgi
> > ** Port directory not found: www/thttpd-notimeout
> > ** Port directory not found: sysutils/dfuife_curses
> > ** Port directory not found: sysutils/libdfui
> > ** Listing the failed packages (*:skipped / !:failed)
> >         ! sysutils/dfuibe_installer (dfuibe_installer-1.0.1)    (port
> > directory error)
> >         ! sysutils/dfuife_cgi (dfuife_cgi-2004.0711)    (port directory
> > error)
> >         ! www/thttpd-notimeout (thttpd-notimeout-2.24)  (port directory
> > error)
> >         ! sysutils/dfuife_curses (dfuife_curses-2004.0711)      (port
> > directory error)
> >         ! sysutils/libdfui (libdfui-2004.0711)  (port directory error)
> > --->  Packages processed: 0 done, 17 ignored, 0 skipped and 5 failed
>
> Thats the dragonfly installer. The errors are there because
> portupgrade tries to upgrade it, since its registered in
> package database, but it doesn't exist in the ports tree.
>
> When these packages fail, other packages depending on them
> will be skipped. But other packages installed will be
> updated, unless there is nothing what to upgrade. See the
> output of "portversion | grep '<'" to see what packages are
> out of date (you need to have up to date ports tree).
>
> -- 
> Sarunas Vancevicius





[Date Prev][Date Next]  [Thread Prev][Thread Next]  [Date Index][Thread Index]