DragonFly On-Line Manual Pages

Search: Section:  


DEVICE_QUIET(9)       DragonFly Kernel Developer's Manual      DEVICE_QUIET(9)

NAME

device_quiet, device_verbose, device_is_quiet -- manipulate device quiet flag

SYNOPSIS

#include <sys/param.h> #include <sys/bus.h> void device_quiet(device_t dev); void device_verbose(device_t dev); int device_is_quiet(device_t dev);

DESCRIPTION

Each device has a quiet flag associated with it. A device is verbose by default when it is created but may be quieted to prevent the device identification string to be printed during probe. To quiet a device, call device_quiet(), to reenable to probe message (to make the message appear again, for example after a device_detach(9)) call device_verbose(). To test to see if a device is quieted, call device_is_quiet().

SEE ALSO

device(9)

AUTHORS

This man page was written by Doug Rabson. DragonFly 5.5 June 21, 1999 DragonFly 5.5

Search: Section: