DragonFly On-Line Manual Pages

Search: Section:  


BIOS(9)               DragonFly Kernel Developer's Manual              BIOS(9)

NAME

bios_sigsearch, BIOS_PADDRTOVADDR, BIOS_VADDRTOPADDR -- interact with PC BIOS

SYNOPSIS

#include <sys/types.h> #include <machine/pc/bios.h> u_int32_t bios_sigsearch(u_int32_t start, u_char *sig, int siglen, int paralen, int sigofs); BIOS_PADDRTOVADDR(addr); BIOS_VADDRTOPADDR(addr);

DESCRIPTION

A number of macros and functions are available to deal with BIOS data encountered on x86 PC-architecture systems. bios_sigsearch() Searches the BIOS address space for a service signature, usually an uppercase ASCII sequence surrounded by underscores. The search begins at start, or at the beginning of the BIOS if start is zero. siglen bytes of the BIOS image and sig are compared at sigofs bytes offset from the current location. If no match is found, the current location is incremented by paralen bytes and the search repeated. If the signature is found, its effective physical address is returned. If no signature is found, zero is returned. BIOS_VADDRTOPADDR() Returns the effective physical address which corresponds to the kernel virtual address addr. BIOS_PADDRTOVADDR() Returns the kernel virtual address which corresponds to the effective physical address addr. DragonFly 4.3 September 9, 2015 DragonFly 4.3

Search: Section: