DragonFly On-Line Manual Pages
AT_EXIT(9) DragonFly Kernel Developer's Manual AT_EXIT(9)
at_exit, rm_at_exit -- ask that a function be run at exit
typedef void (exitlist_fn) (struct proc *);
The at_exit facility allows a kernel module to ensure that it is notified
at any process exit. The function func is called with the a pointer to
the exiting process's proc structure.
If the requirement for notification is removed, then the function
rm_at_exit() must be called with the exact func argument as the corre-
sponding call to at_exit().
The at_exit() function returns an errno, 0 meaning success. The
rm_at_exit() function returns the number of items removed (should be 0 or
The at_exit() function appeared in FreeBSD 2.2.
The function was written by Julian Elischer <julian@FreeBSD.org>.
DragonFly 3.7 August 15, 1996 DragonFly 3.7