DragonFly On-Line Manual Pages

Search: Section:  


VOP_LEASE(9)	      DragonFly Kernel Developer's Manual	  VOP_LEASE(9)

NAME

VOP_LEASE -- validate a vnode for a particular set of credentials and operation type

SYNOPSIS

#include <sys/param.h> #include <sys/mount.h> int VOP_LEASE(struct vnode *vp, struct proc *p, struct ucred *cred, int type);

DESCRIPTION

This entry point is currently not implemented. I believe the idea is to validate a vnode for a particular set of user credentials and operation type. The two operation types supported are LEASE_READ and LEASE_WRITE. The function currently always returns 0.

LOCKS

The vnode must be exclusively locked on entry, and should remain exclu- sively locked on return.

RETURN VALUES

If successful, zero is returned. Otherwise, well... zero is returned too.

SEE ALSO

VOP_READ(9), VOP_WRITE(9)

AUTHORS

This man page was written by Matt Dillon. DragonFly 4.1 September 24, 1999 DragonFly 4.1

Search: Section: