DragonFly On-Line Manual Pages

Search: Section:  


VOP_GETPAGES(9)       DragonFly Kernel Developer's Manual      VOP_GETPAGES(9)

NAME

VOP_GETPAGES, VOP_PUTPAGES - read or write VM pages from a file

SYNOPSIS

#include <sys/param.h> #include <sys/vnode.h> #include <vm/vm.h> int VOP_GETPAGES(struct vnode *vp, vm_page_t *m, int count, int reqpage, vm_ooffset_t offset, int seqaccess); int VOP_PUTPAGES(struct vnode *vp, vm_page_t *m, int count, int flags, int *rtvals, vm_ooffset_t offset);

DESCRIPTION

The arguments are: vp The file to access. m Pointer to a page array representing a contiguous region of the file to be read or written. count The length of this array. flags OBJPC_* flags, see <vm/vm_pager.h>. rtvals An array of VM system result codes indicating the status of each page written by VOP_PUTPAGES(). reqpage Index of the requested page. offset Offset in the file to start accessing. seqaccess Sequential access.

RETURN VALUES

Zero is returned on success, otherwise an error is returned.

SEE ALSO

vnode(9)

AUTHORS

This man page was written by Doug Rabson. DragonFly 5.9-DEVELOPMENT May 6, 2020 DragonFly 5.9-DEVELOPMENT

Search: Section: