DragonFly On-Line Manual Pages

Search: Section:  


VOP_CREATE(9)	      DragonFly Kernel Developer's Manual	 VOP_CREATE(9)

NAME

VOP_CREATE, VOP_MKNOD, VOP_MKDIR, VOP_SYMLINK -- create a file, socket, fifo, device, directory or symlink

SYNOPSIS

#include <sys/param.h> #include <sys/vnode.h> #include <sys/namei.h> int VOP_CREATE(struct vnode *dvp, struct vnode **vpp, struct componentname *cnp, struct vattr *vap); int VOP_MKNOD(struct vnode *dvp, struct vnode **vpp, struct componentname *cnp, struct vattr *vap); int VOP_MKDIR(struct vnode *dvp, struct vnode **vpp, struct componentname *cnp, struct vattr *vap); int VOP_SYMLINK(struct vnode *dvp, struct vnode **vpp, struct componentname *cnp, struct vattr *vap, char *target);

DESCRIPTION

These entry points create a new file, socket, fifo, device, directory or symlink in a given directory. The arguments are: dvp the locked vnode of the directory vpp the address of a variable where the resulting locked vnode should be stored cnp the pathname component created vap the attributes that the new object should be created with target the pathname of the target of the symlink These entry points are called after VOP_LOOKUP(9) when an object is being created. Normally, VOP_LOOKUP(9) will have set the SAVENAME flag in cnp->cn_flags to keep the memory pointed to by cnp->cn_pnbuf valid. If an error is detected when creating the file, then this memory will be freed. If the file is created successfully, then it will be freed unless the SAVESTART flag is specified in cnp.

LOCKS

The directory, dvp will be locked on entry and must remain locked on return. If the call is successful, the new object will be returned locked.

RETURN VALUES

If successful, the vnode for the new object is placed in *vpp and zero is returned. Otherwise, an appropriate error is returned.

PSEUDOCODE

int vop_create(struct vnode *dvp, struct vnode **vpp, struct componentname *cnp struct vattr *vap) { int mode = MAKEIMODE(vap->va_type, vap->va_mode); struct vnode *vp; int error; *vpp = NULL; if ((mode & IFMT) == 0) mode |= IFREG; error = SOMEFS_VALLOC(dvp, mode, cnp->cn_cred, &vp); if (error) { kfree(cnp->cn_pnbuf, M_NAMEI); vput(dvp); return error; } /* * Update the permissions for the new vnode, including * copying the group from the directory. */ ...; #ifdef QUOTA /* * Possibly check quota information. */ ...; #endif /* * Enter new vnode in directory, taking care that the vnode * hits the disk before the directory contents are changed. */ error = ...; if (error) goto bad; if ((cnp->cn_flags & SAVESTART) == 0) kfree(cnp->cn_pnbuf, M_NAMEI); vput(dvp); *vpp = vp; return 0; bad: /* * Write error occurred trying to update the inode * or the directory so must deallocate the inode. */ kfree(cnp->cn_pnbuf, M_NAMEI); vput(vp); /* * Deallocate filesystem resources for vp. */ ...; vput(dvp); return error; }

ERRORS

[ENOSPC] The filesystem is full. [EDQUOT] Quota exceeded.

SEE ALSO

vnode(9), VOP_LOOKUP(9)

HISTORY

The function VOP_CREATE appeared in 4.3BSD.

AUTHORS

This man page was written by Doug Rabson. DragonFly 3.9 July 24, 1996 DragonFly 3.9

Search: Section: