DragonFly On-Line Manual Pages

Search: Section:  


VOP_ADVLOCK(9)        DragonFly Kernel Developer's Manual       VOP_ADVLOCK(9)

NAME

VOP_ADVLOCK -- advisory record locking

SYNOPSIS

#include <sys/param.h> #include <sys/vnode.h> #include <sys/fcntl.h> #include <sys/lockf.h> int VOP_ADVLOCK(struct vnode *vp, caddr_t id, int op, struct flock *fl, int flags);

DESCRIPTION

The arguments are: vp the vnode being manipulated id the id token which is changing the lock op the operation to perform (see fcntl(2)) fl description of the lock flags One of more of the following: F_RDLCK shared or read lock F_UNLCK unlock F_WRLCK exclusive or write lock F_WAIT Wait until lock is granted F_POSIX Use POSIX semantics for lock This entry point manipulates advisory record locks on the file. Most filesystems delegate the work for this call to lf_advlock().

RETURN VALUES

Zero is returned on success, otherwise an error is returned.

SEE ALSO

fcntl(2), flock(2), vnode(9)

AUTHORS

This man page was written by Doug Rabson. DragonFly 3.5 June 30, 1999 DragonFly 3.5

Search: Section: