DragonFly On-Line Manual Pages

Search: Section:  


VFS_ROOT(9)           DragonFly Kernel Developer's Manual          VFS_ROOT(9)

NAME

VFS_ROOT -- return the root vnode of a filesystem

SYNOPSIS

#include <sys/param.h> #include <sys/mount.h> #include <sys/vnode.h> int VFS_ROOT(struct mount *mp, struct vnode **vpp);

DESCRIPTION

Return a locked vnode for the root directory of the filesystem. Its arguments are: mp The filesystem. vpp Return parameter for the root vnode.

SEE ALSO

VFS(9), vnode(9)

AUTHORS

This man page was written by Doug Rabson. DragonFly 3.5 July 24, 1996 DragonFly 3.5

Search: Section: