DragonFly On-Line Manual Pages
DEVICE_DETACH(9) DragonFly Kernel Developer's Manual DEVICE_DETACH(9)
DEVICE_DETACH -- detach a device
Detach a device. This can be called if the user is replacing the driver
software or if a device is about to be physically removed from the system
(e.g. for pccard devices).
The method should deallocate any system resources allocated during the
DEVICE_ATTACH(9) method and reset the hardware to a sane state (i.e. dis-
able interrupts etc.)
Zero is returned on success, otherwise an appropriate error is returned.
This man page was written by Doug Rabson.
DragonFly 3.7 June 16, 1998 DragonFly 3.7