DragonFly On-Line Manual Pages
YPPUSH(8) DragonFly System Manager's Manual YPPUSH(8)
yppush -- force propagation of updated NIS databases
yppush [-d domain] [-t timeout] [-j #parallel jobs] [-h host] [-p path]
The yppush utility distributes updated NIS databases (or maps) from an
NIS master server to NIS slave servers within an NIS domain. It is nor-
mally only run on the NIS master by /var/yp/Makefile whenever any of the
NIS maps are updated. Note that /var/yp/Makefile does not invoke yppush
by default: the ``NOPUSH=True'' entry in the Makefile must first be com-
mented out (the default DragonFly configuration assumes a small network
with only a single NIS server; in such a configuration, yppush is not
By default, yppush determines the names of the slave servers for a domain
by searching the ypservers map. A destination host (or a list of hosts)
can also be manually specified on the command line. Once it has a com-
plete list of slave servers, it sends a 'map transfer' request to each
slave, which in turn reads a copy of the map from the master NIS server
using ypxfr(8). Included within each request is the name of the map to
be copied and some special information required by ypxfr(8) to success-
fully 'callback' to yppush and carry out the transfer. Any error mes-
sages yppush receives from ypxfr(8) via callback will be printed to
The following options are available:
Specify a particular domain. The NIS domain of the local host
system is used by default. If the local host's domain name is
not set, the domain name must be specified with this flag.
Specify a timeout value in seconds. This timeout controls how
long yppush will wait for a response from a slave server before
sending a map transfer request to the next slave server in its
-j #parallel jobs
The yppush utility normally performs transfers serially, meaning
that it will send a map transfer request to one slave server and
then wait for it to respond before moving on to the next slave
server. In environments with many slaves, it is more efficient
to initiate several map transfers at once so that the transfers
can take place in parallel. The -j flag is used to specify the
desired number of parallel jobs: yppush will initiate the speci-
fied number of transfers immediately and listen for responses.
If the number of specified parallel jobs is less than the number
of slave servers, yppush will initiate only the number of speci-
fied jobs and then wait for some of them to finish before start-
ing any more.
Note that yppush handles callbacks asynchronously, which means
that it will collect and display the callback information
received from ypxfr(8) as soon as it arrives, even it arrives
before all of the map transfer requests have been sent.
Can be used to transfer a map to a user-specified machine or
group of machines instead of the list of servers contained in the
ypservers map. A list of hosts can be specified by using multi-
ple instances of the -h flag.
By default, yppush expects all the local NIS maps to be stored
under /var/yp. The -p flag can be used to specify an alternate
path in the event that the system administrator decides to store
the NIS maps somewhere else.
-v Verbose mode: it causes yppush to print debugging messages as it
runs. Specifying this flag twice makes yppush even more verbose.
/var/yp/[domainname]/ypservers the NIS ypservers map containing the
names of all servers in a particular
yp(8), ypserv(8), ypxfr(8)
Bill Paul <firstname.lastname@example.org>
The mechanism for transferring NIS maps in NIS v1 is different than that
in NIS version 2. This version of yppush has support for transferring
maps to NIS v2 systems only.
DragonFly 4.1 February 5, 1995 DragonFly 4.1