DragonFly On-Line Manual Pages

Search: Section:  


VM_PAGE_ALLOC(9)      DragonFly Kernel Developer's Manual     VM_PAGE_ALLOC(9)

NAME

vm_page_alloc -- allocate a page for a vm_object

SYNOPSIS

#include <sys/param.h> #include <vm/vm.h> #include <vm/vm_page.h> vm_page_t vm_page_alloc(vm_object_t object, vm_pindex_t pindex, int page_req);

DESCRIPTION

The vm_page_alloc() function allocates a page at pindex within object. It is assumed that a page has not already been allocated at pindex. The page returned is inserted into the object, but is not inserted into the pmap. The vm_object must be locked on entry. vm_page_alloc() will not block. Its arguments are: object The VM object to allocate the page for. pindex The index into the object at which the page should be inserted. page_req A flag indicating how the page should be allocated. VM_ALLOC_NORMAL The page should be allocated with no special treatment. VM_ALLOC_QUICK The page should only be allocated from the free queue. VM_ALLOC_SYSTEM The page can be allocated if the cache queue is empty and the free page count is above the interrupt reserved water mark. If VM_ALLOC_INTERRUPT is set, the page can be allocated as long as the free page count is greater than zero. This flag should be used only when the system really needs the page. VM_ALLOC_INTERRUPT vm_page_alloc() is being called during an interrupt and therefore the cache cannot be accessed. The page will only be returned successfully if the free count is greater than zero. VM_ALLOC_ZERO Indicate a preference for a pre-zeroed page. There is no guarantee that the page thus returned will be zeroed, but it will be marked as such.

RETURN VALUES

The vm_page_t that was allocated is returned if successful; otherwise, NULL is returned. The returned page will be marked busy.

AUTHORS

This manual page was written by Chad David <davidc@acns.ab.ca>. DragonFly 5.3 May 20, 2018 DragonFly 5.3

Search: Section: