DragonFly On-Line Manual Pages
VGA(4) DragonFly Kernel Interfaces Manual VGA(4)
vga, vesa -- generic video card interface
device vga0 at isa? port ?
The vga driver is a generic video card driver which provides access to
video cards. This driver is required for the console driver syscons(4).
The console driver will call the vga driver to manipulate video hardware
(changing video modes, loading font, etc).
The vga driver supports the standard VGA video cards. In addition, the
driver can utilize the VESA BIOS Extension if the video card supports it.
VESA support can either be statically included in the kernel or can be
loaded as a separate module.
In order to statically link the VESA support into the kernel, the VESA
option (see below) must be defined in the kernel configuration file.
The vesa module can be dynamically loaded into the kernel using
Kernel Configuration Options
The following kernel configuration options (see config(8)) can be used to
control the vga driver. These options provide compatibility with certain
VGA_DEBUG=N Set the VGA support debug level to N. The default
value is 0, which suppresses all debugging output.
A value of 2 gives maximum verbosity.
VGA_KEEP_POWERON_MODE This option keeps the initial mode's register set-
tings for switching back to it from another mode.
VGA_WIDTH90 This option enables 90 column modes: 90x25, 90x30,
90x43, 90x50, 90x60. These modes are not always
supported by the video card and the display. It
is highly likely that LCD display cannot work with
The following options will remove some features from the vga driver and
save kernel memory.
VGA_NO_FONT_LOADING This option removes font loading from the driver.
Note that if you use this option and still wish to
use the mouse on the console then you must also
use the SC_ALT_MOUSE_IMAGE option. See
VGA_NO_MODE_CHANGE This option prevents the driver from changing
The following options add optional features to the driver.
VESA Add VESA BIOS Extension support to the driver. If
the VGA card has the VESA BIOS Extension 1.2 or
later, this option will utilize it to switch to
high resolution modes.
VESA_DEBUG=N Set the VESA support debug level to N. The
default value is 0, which suppresses all debugging
output. A value of 2 gives maximum verbosity.
Your kernel configuration should normally have:
device vga0 at isa? port ?
The following line should be included in the kernel configuration file in
order to enable the VESA BIOS Extension support.
If you do not want VESA support included in the kernel, but want to use
occasionally, do not add the VESA option. And load the vesa module as
vgl(3), syscons(4), config(8), kldload(8), kldunload(8)
Apple, IBM, Motorola, "Common Hardware Reference Platform: I/O Device
Reference", Appendix A: VGA Programming Model, p. 195,
Video Electronics Standards Association, VESA BIOS Extension (VBE).
The vga driver first appeared in FreeBSD 3.1.
The vga driver was written by Soren Schmidt <sos@FreeBSD.org> and
Kazutaka Yokota <yokota@FreeBSD.org>. This manual page was written by
DragonFly 4.3 December 14, 2009 DragonFly 4.3