DragonFly On-Line Manual Pages

Search: Section:  


VFS(7)            DragonFly Miscellaneous Information Manual            VFS(7)

NAME

vfs - vfs layer under DragonFly

DESCRIPTION

On DragonFly all filesystems are handled through the vfs abstraction layer.

SYSCTL VARIABLES

sysctl(8) variables permit system behavior to be monitored and controlled at run-time. Some sysctls simply report on the behavior of the system; others allow the vfs behavior to be modified; In this document we will only cover the ones that are generic to vfs and not specific to any of filesystems. debug.disablecwd Disables the getcwd() functionality. debug.disablefullpath Disables fullpath lookups. debug.nchash Size of namecache hash table. debug.nclockwarn Warn on locked namecache entries in ticks. debug.ncmount_cache_enable Prints the status if mount point cache is enabled. debug.ncnegfactor Ratio of namecache negative entries. debug.ncp_shared_lock_disable Disables shared namecache locks. debug.ncnegflush Batch flush negative entries. debug.ncposflush Batch flush positive entries. debug.ncposlimit Number of cache entries allocated. debug.ncvp_debug Controls namecache debug level (0-3). debug.numdefered Number of cache entries allocated. debug.numvnodes Prints currently allocated vnode count. debug.verbose_reclaims Outputs filename of reclaimed vnodes. vfs.bufcache_bw Controls data cycling within the buffer cache. vfs.bufspace Amount of memory available for buffers. vfs.cache.numcache Number of namecaches entries. vfs.cache.numleafs Number of namecaches entries. vfs.cache.numneg Number of negative namecache entries. vfs.check_buf_overlap Controls overlapping buffer checking. vfs.debug_bufbio, vfs.debug_commit vfs.debug_kvabio Enables debugging of specific sub systems. vfs.dirtybufcount Pending number of dirty buffers. vfs.dirtybufcounthw Pending number of dirty buffers (heavy weight). vfs.dirtybufspace Pending bytes of dirty buffers (all). vfs.dirtybufspacehw Pending bytes of dirty buffers (heavy weight). vfs.dirtykvaspace KVA reserved by dirty buffers (all). vfs.flushperqueue Number of buffers to flush from each per-cpu queue. vfs.getnewbufcalls New buffer header acquisition requests. vfs.hibufspace Minimum amount of memory to reserve for system buffer space. vfs.hidirtybufspace High watermark used to trigger explicit flushing of dirty buffers. vfs.hirunningspace Sysctl determines how much outstanding write I/O may be queued to disk controllers system wide at any given instance. vfs.lobufspace Minimum amount of memory to reserve for system buffer space. vfs.lodirtybufspace Number of dirty buffers to flush before bufdaemon becomes inactive. vfs.lorunningspace Minimum amount of buffer space required for active I/O. vfs.lowmempgallocs Page allocations done during periods of very low free memory. vfs.max_readahead Limit in bytes for desired cluster read-ahead. vfs.maxbufspace Minimum amount of memory to reserve for system buffer space. vfs.maxmallocbufspace Maximum amount of memory reserved for buffers using malloc. vfs.nbuf Total number of buffers in buffer cache. vfs.quota_enabled Enables vfs quota. vfs.real_root Prints real root mount string. vfs.reassignbufcalls Prints a number of times buffers have been reassigned to the proper list. Counter can be safely reseted back to 0. vfs.runningbufcount I/O buffers currently in progress due to asynchronous writes. vfs.runningbufspace I/O bytes currently in progress due to asynchronous writes. vfs.timestamp_precision Controls granularity used on file timestamps. 0 - seconds only, nanoseconds zeroed. 1 - seconds and nanoseconds, accurate within 1/HZ. 2 - seconds and nanoseconds, truncated to microseconds. 3 - seconds and nanoseconds, maximum precision. vfs.usermount Allows non-root users to mount filesystems. vfs.varsym_enable Enables Variant Symlinks. vfs.vm_cycle_point Controls active or inactive pages queue transition. vfs.write_behind Sysctl defaults to 1 (on). This tells the filesystem to issue media writes as full clusters are collected, which typically occurs when writing large sequential files. vfs.write_behind_minfilesize kern.chroot_allow_open_directories 0 - disallowed for all processes. 1 - allowed for processes that were not already chroot(2)'ed. 2 - allowed for all processes. kern.maxvnodes Specifies how many vnodes and related file structures the kernel will cache. The kernel uses a very generous default for this parameter based on available physical memory. security.hardlink_check_gid Unprivileged processes cannot create hard links to files owned by other groups. security.hardlink_check_uid Unprivileged processes cannot create hard links to files owned by other users.

SEE ALSO

autofs(5), devfs(5), ffs(5), hammer(5), tuning(7), vkernel(7), swapcache(8), sysctl(8), tunefs(8)

HISTORY

The vfs manual first appeared in DragonFly 5.1. DragonFly 5.9-DEVELOPMENT February 17, 2018 DragonFly 5.9-DEVELOPMENT

Search: Section: