DragonFly On-Line Manual Pages

Search: Section:  


USB(4)                DragonFly Kernel Interfaces Manual                USB(4)

NAME

usb - Universal Serial Bus

SYNOPSIS

To compile this driver into the kernel, place the following line in your kernel configuration file: device usb Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): usb_load="YES"

USERLAND PROGRAMMING

USB functions can be accessed from userland through the libusb library. See libusb(3) for more information.

DESCRIPTION

DragonFly provides machine-independent bus support and drivers for USB devices in host and device side mode. The usb driver has three layers: USB Controller (Bus) USB Device USB Driver The controller attaches to a physical bus like pci(4). The USB bus attaches to the controller, and the root hub attaches to the controller. Any devices attached to the bus will attach to the root hub or another hub attached to the USB bus. The uhub device will always be present as it is needed for the root hub. DragonFly provides support for the following devices. Storage devices umass(4) Mass Storage Devices, e.g., external disk drives urio(4) Diamond Rio 500 MP3 player usfs(4) Mass storage driver for device-side mode Wired network interfaces aue(4) ADMtek AN986 Pegasus Ethernet driver axe(4) ASIX Electronics AX88x7x/760 USB Ethernet driver axge(4) ASIX Electronics AX88178A/AX88179 USB Gigabit Ethernet driver cdce(4) USB Communication Device Class Ethernet driver cue(4) CATC USB-EL1210A Ethernet driver ipheth(4) USB Apple iPhone/iPad tethered Ethernet driver kue(4) Kawasaki LSI KL5KUSB101B Ethernet driver mos(4) Moschip MCS7730/MCS7830/MCS7832 USB Ethernet driver udav(4) Davicom DM9601 USB Ethernet driver Wireless network interfaces rum(4) Ralink Technology RT2501USB/RT2601USB IEEE 802.11 driver run(4) Ralink Technology RT2700U/RT2800U/RT3000U IEEE 802.11 driver urndis(4) RNDIS USB ethernet driver urtwn(4) Realtek RTL8188CU/RTL8192CU IEEE 802.11 driver Serial and parallel interfaces u3g(4) support for 3G datacards uark(4) Arkmicro Technologies ARK3116 based serial adapters ubsa(4) Belkin serial adapters ubser(4) support for BWCT console serial adapters uchcom(4) WinChipHead CH341/CH340 serial adapters ucom(4) tty support ucycom(4) Cypress CY7C63743 and CY7C64013 USB to RS232 bridges ufoma(4) mobile phone support uftdi(4) serial devices based on the FTDI chips ugensa(4) generic serial device uipaq(4) support for iPAQ units ulpt(4) printer support umcs(4) serial adapters based on the MCS7820 and MCS7840 chips umct(4) Magic Control Technology USB-232 based serial adapters umodem(4) modem support umoscom(4) serial adapters based on the MCS7703 chip uplcom(4) Prolific PL-2303/2303X/2303HX serial adapters uslcom(4) Silicon Laboratories CP2101, CP2102 and CP2103 USB to serial bridge uvisor(4) support for the Handspring Visor, a Palmpilot compatible PDA uvscom(4) SUNTAC Slipper U VS-10U serial adapters Audio devices uaudio(4) audio device driver Radio receiver devices ufm(4) Cypress Semiconductor FM Radio Human Interface Devices uep(4) eGalax touchscreen driver uhid(4) generic driver for Human Interface Devices ukbd(4) keyboards that follow the boot protocol ums(4) mouse devices wsp(4) Wellspring touchpad driver for Apple laptops

INTRODUCTION TO USB

The USB is a system where external devices can be connected to a PC. The most common USB speeds are: Low Speed (1.5MBit/sec) Full Speed (12MBit/sec) High Speed (480MBit/sec) Each USB has a USB controller that is the master of the bus. The physical communication is simplex which means the host controller only communicates with one USB device at a time. There can be up to 127 devices connected to an USB HUB tree. The addresses are assigned dynamically by the host when each device is attached to the bus. Within each device there can be up to 16 endpoints. Each endpoint is individually addressed and the addresses are static. Each of these endpoints will communicate in one of four different modes: control, isochronous, bulk, or interrupt. A device always has at least one endpoint. This endpoint has address 0 and is a control endpoint and is used to give commands to and extract basic data, such as descriptors, from the device. Each endpoint, except the control endpoint, is unidirectional. The endpoints in a device are grouped into interfaces. An interface is a logical unit within a device; e.g. a compound device with both a keyboard and a trackball would present one interface for each. An interface can sometimes be set into different modes, called alternate settings, which affects how it operates. Different alternate settings can have different endpoints within it. A device may operate in different configurations. Depending on the configuration, the device may present different sets of endpoints and interfaces. The bus enumeration of the USB bus proceeds in several steps: 1. Any interface specific driver can attach to the device. 2. If none is found, generic interface class drivers can attach.

SEE ALSO

The USB specifications can be found at: http://www.usb.org/developers/docs/ usbhidaction(1), usbhidctl(1), libusb(3), libusb20(3), usbhid(3), aue(4), axe(4), axge(4), cdce(4), cue(4), ehci(4), ipheth(4), kue(4), mos(4), ohci(4), pci(4), rum(4), run(4), u3g(4), uark(4), uaudio(4), ubsa(4), ubser(4), uchcom(4), ucom(4), ucycom(4), udav(4), uep(4), ufm(4), ufoma(4), uftdi(4), ugen(4), ugensa(4), uhci(4), uhid(4), uipaq(4), ukbd(4), ulpt(4), umass(4), umcs(4), umct(4), umodem(4), umoscom(4), ums(4), uplcom(4), urio(4), urndis(4), urtwn(4), usb_template(4), usfs(4), uslcom(4), uvisor(4), uvscom(4), wsp(4), xhci(4), usbconfig(8), usbdi(9)

STANDARDS

The usb module complies with the USB 2.0 standard.

HISTORY

The usb module has been inspired by the NetBSD USB stack initially written by Lennart Augustsson. The usb module was written by Hans Petter Selasky <hselasky@FreeBSD.org>. DragonFly 6.1-DEVELOPMENT July 3, 2021 DragonFly 6.1-DEVELOPMENT

Search: Section: