DragonFly On-Line Manual Pages
URTWN(4) DragonFly Kernel Interfaces Manual URTWN(4)
urtwn -- Realtek RTL8188CU/RTL8192CU USB IEEE 802.11b/g/n wireless net-
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
In both cases, place the following line in loader.conf(5) to acknowledge
the firmware license (see below):
The urtwn driver supports USB 2.0 wireless network devices based on Real-
tek RTL8188CUS, RTL8188CE-VAU, RTL8188RU and RTL8192CU chipsets.
The RTL8188CUS is a highly integrated 802.11n adapter that combines a
MAC, a 1T1R capable baseband and an RF in a single chip. It operates in
the 2GHz spectrum only. The RTL8188RU is a high-power variant of the
RTL8188CUS. The RTL8188CE-VAU is a PCI Express Mini Card adapter that
attaches to the USB interface.
The RTL8192CU is a highly integrated multiple-in, multiple-out (MIMO)
802.11n adapter that combines a MAC, a 2T2R capable baseband and an RF in
a single chip. It operates in the 2GHz spectrum only.
This driver requires the firmware built with the urtwnfw(4) module to
work. For the loaded firmware to be enabled for use the license at
/usr/share/doc/legal/realtek/LICENSE must be agreed to by adding the fol-
lowing line to loader.conf(5):
/usr/share/doc/legal/realtek/LICENSE urtwn firmware license
The following adapters should work:
Belkin F7D1102 Surf Wireless Micro
Join an existing BSS network (i.e., connect to an access point):
ifconfig wlan create wlandev urtwn0 inet 192.168.0.20 \
Join a specific BSS network with network name ``my_net'':
ifconfig wlan create wlandev urtwn0 ssid my_net up
Join a specific BSS network with 64-bit WEP encryption:
ifconfig wlan create wlandev urtwn0 ssid my_net \
wepmode on wepkey 0x1234567890 weptxkey 1 up
urtwn%d: error %d, could not read firmware %s For some reason, the
driver was unable to read the microcode file from the filesystem. The
file might be missing or corrupted.
urtwn%d: device timeout A frame dispatched to the hardware for transmis-
sion did not complete in time. The driver will reset the hardware. This
should not happen.
ifmedia(4), intro(4), netintro(4), urtwnfw(4), usb(4), wlan(4),
wlan_ccmp(4), wlan_tkip(4), wlan_wep(4), ifconfig(8), wpa_supplicant(8)
The urtwn driver first appeared in OpenBSD 4.9 and FreeBSD 10.0.
The urtwn driver was written by Damien Bergamini <firstname.lastname@example.org>.
The urtwn driver does not support any of the 802.11n capabilities offered
by the adapters.
DragonFly 3.7 March 16, 2014 DragonFly 3.7