DragonFly On-Line Manual Pages
UMASS(4) DragonFly Kernel Interfaces Manual UMASS(4)
umass -- USB Mass Storage Devices driver
The umass driver provides support for Mass Storage devices that attach to
the USB port. Supported are
* Iomega USB Zip 100 drive
* Iomega USB Zip 250 drive
* Microtech International, Inc. USB-SCSI-HD 50 USB to SCSI cable.
* Panasonic ("Matshita FDD CF-VFDU03")
* Trek Thumbdrive 8MB
* VAIO floppy drive (includes Y-E Data Flashbuster-U)
The driver also supports some USB adapters for removable media. Among
the supported models are:
* SanDisk SDDR-31 (Compact Flash)
* SanDisk SDDR-75 (only Compact Flash port works)
* Sitecom CN-300 MultiFlash (MMC/SD, SmartMedia, CF, MemoryStick)
usb and one of uhci or ohci must be configured in the kernel as well.
Last but not least, support for SCSI drives, da
Add the umass driver to the kernel.
camcontrol rescan 0
Rescan a Zip drive that was added after boot. The command above assumes
that the Zip drive is the first SCSI bus in the system.
camcontrol rescan 0:0:0
camcontrol rescan 0:0:1
camcontrol rescan 0:0:2
camcontrol rescan 0:0:3
Rescan all slots on a multi-slot flash reader, where the slots map to
separate LUNs on a single SCSI ID. Typically only the first slot will be
enabled at boot time. Again, this assumes that the flash reader is the
first SCSI bus in the system.
disklabel -w -r da0s0 zip100
mount -t ufs /dev/da0s0c /mnt
Write a disklabel to the Zip drive (see vpo for the disktab entry), cre-
ates the filesystem and mounts the new filesystem on /mnt.
Create a new FAT type filesystem.
ohci(4), uhci(4), usb(4), vpo(4), disktab(5), camcontrol(8), disklabel(8)
The umass driver was written by MAEKAWA Masahide <firstname.lastname@example.org>
and Nick Hibma <n_hibma@FreeBSD.org>.
This manual page was written by Nick Hibma <n_hibma@FreeBSD.org>.
DragonFly 3.7 May 3, 1999 DragonFly 3.7