DragonFly On-Line Manual Pages
UGURU(4) DragonFly Kernel Interfaces Manual UGURU(4)
uguru -- ABIT temperature, voltage and fan sensors
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
device uguru0 at isa? port 0xe0
Alternatively, to load the driver as a module at boot time, place the
following lines in loader.conf(5):
The uguru driver provides support for the microcontroller found in vari-
ous ABIT motherboards which serves as the gateway chip between system
management software and hardware. Sensor values are made available
through the sysctl(8) interface.
intro(4), isa(4), sensorsd(8), sysctl(8)
The uguru driver first appeared in OpenBSD 4.8.
The uguru driver was written by Mikko Tolmunen <firstname.lastname@example.org>. It
was adapted to DragonFly by Sascha Wildner.
Interrupt support is unimplemented.
DragonFly 4.3 October 17, 2010 DragonFly 4.3