DragonFly On-Line Manual Pages
SMBUS(4) DragonFly Kernel Interfaces Manual SMBUS(4)
smbus -- System Management Bus
The smbus system provides a uniform, modular and architecture-independent
system for the implementation of drivers to control various SMB devices
and to utilize different SMB controllers (I2C, PIIX4, Brooktree848,
System Management Bus
The System Management Bus is a two-wire interface through which simple
power-related chips can communicate with rest of the system. It uses I2C
as its backbone (see iicbus(4)).
A system using SMB passes messages to and from devices instead of trip-
ping individual control lines.
With the SMBus, a device can provide manufacturer information, tell the
system what its model/part number is, save its state for a suspend event,
report different types of errors, accept control parameters, and return
The SMBus may share the same host device and physical bus as ACCESS bus
components provided that an appropriate electrical bridge is provided
between the internal SMB devices and external ACCESS bus devices.
bktr(4), iicbus(4), iicsmb(4), smb(4)
The smbus manual page first appeared in FreeBSD 3.0.
This manual page was written by Nicolas Souchu.
DragonFly 3.5 August 10, 1998 DragonFly 3.5