DragonFly On-Line Manual Pages
SILI(4) DragonFly Kernel Interfaces Manual SILI(4)
sili -- Silicon Image 3124/3132 SATA controller
To compile this driver into the kernel, place the following line in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The sili driver provides support for SATA controllers using the Silicon
Image 3124/3132 SATALink chipsets. Both 3124-1 (1.5 Gbps) and 3124-2 (3
Gbps) versions of the 3124 chip are supported.
Although sili controllers are actual ATA controllers, the driver emulates
SCSI via a translation layer.
The following hints may be set in loader.conf(5) to control the sili
driver's behavior. Note that the hint need only exist, so removing it
requires commenting it out.
Usually both the nata(4) and the sili drivers are loaded. The nata(4)
driver will pick up any ata-like devices which the sili driver misses.
If the sili driver is disabled the nata(4) driver will typically pick up
the sili devices, albeit under the ad disk name rather than the da disk
The sili driver can be told to force a lower-speed 1.5Gb link speed if
necessary, and can also be told to refrain from attempting to send cer-
tain higher-level ATA commands to initialize ATA features which some
devices might not properly implement.
The sili driver supports MSI but support is turned off by default. It
can be enabled by setting the hw.sili.msi.enable tunable to 1.
ahci(4), intro(4), nata(4), pci(4), scsi(4), loader.conf(5)
The sili driver first appeared in DragonFly 2.3.
The sili driver was originally written by David Gwynne <firstname.lastname@example.org>
and Christopher Pascoe <email@example.com> for OpenBSD.
It was ported to DragonFly by Matt Dillon <firstname.lastname@example.org>,
who added new features such as hot-plug and port multiplier support.
DragonFly 3.9 December 4, 2013 DragonFly 3.9