DragonFly On-Line Manual Pages
SETKEY(8) DragonFly System Manager's Manual SETKEY(8)
setkey -- manually manipulate the IPsec SA/SP database
setkey [-dv] -c
setkey [-dv] -f filename
setkey [-adPlv] -D
setkey [-dPv] -F
setkey [-h] -x
The setkey utility adds, updates, dumps, or flushes Security Association
Database (SAD) entries as well as Security Policy Database (SPD) entries
in the kernel.
The setkey utility takes a series of operations from the standard input
(if invoked with -c) or the file named filename (if invoked with -f
-D Dump the SAD entries. If with -P, the SPD entries are dumped.
-F Flush the SAD entries. If with -P, the SPD entries are flushed.
-a Dead SAD entries are usually not displayed with -D. If with -a,
the dead SAD entries will be displayed as well. A dead SAD entry
means that it has been expired but remains because it is refer-
enced by SPD entries.
-d Enable to print debugging messages for command parser, without
talking to kernel. It is not used usually.
-x Loop forever and dump all the messages transmitted to PF_KEY
socket. -xx makes each timestamp unformatted.
-h Add hexadecimal dump on -x mode.
-l Loop forever with short output on -D.
-v Be verbose. The program will dump messages exchanged on PF_KEY
socket, including messages sent from other processes to the ker-
Operations have the following grammar. Note that lines starting with
hashmarks ('#') are treated as comment lines.
add src dst protocol spi [extensions] algorithm... ;
Add an SAD entry.
get src dst protocol spi ;
Show an SAD entry.
delete src dst protocol spi ;
Remove an SAD entry.
deleteall src dst protocol ;
Remove all SAD entries that match the specification.
flush [protocol] ;
Clear all SAD entries matched by the options.
dump [protocol] ;
Dumps all SAD entries matched by the options.
spdadd src_range dst_range upperspec policy ;
Add an SPD entry.
spddelete src_range dst_range upperspec -P direction ;
Delete an SPD entry.
Clear all SPD entries.
Dumps all SPD entries.
Meta-arguments are as follows:
dst Source/destination of the secure communication is specified as
IPv4/v6 address. The setkey utility does not consult hostname-
to-address for arguments src and dst. They must be in numeric
protocol is one of following:
esp ESP based on rfc2405
esp-old ESP based on rfc1827
ah AH based on rfc2402
ah-old AH based on rfc1826
tcp TCP-MD5 based on rfc2385
spi Security Parameter Index (SPI) for the SAD and the SPD. It must
be decimal number or hexadecimal number You cannot use the set of
SPI values in the range 0 through 255. (with 0x attached). TCP-
MD5 associations must use 0x1000 and therefore only have per-host
granularity at this time.
takes some of the following:
-m mode Specify a security protocol mode for use. mode is
one of following: transport, tunnel or any. The
default value is any.
-r size Specify window size of bytes for replay prevention.
size must be decimal number in 32-bit word. If size
is zero or not specified, replay check don't take
-u id Specify the identifier of the policy entry in SPD.
defines the content of the ESP padding. pad_option
is one of following:
zero-pad All of the padding are zero.
random-pad A series of randomized values are set.
seq-pad A series of sequential increasing numbers
started from 1 are set.
Don't allow cyclic sequence number.
-ls time Specify hard/soft life time duration of the SA.
-E ealgo key
Specify an encryption algorithm.
-A aalgo key
Specify an authentication algorithm. If -A is used
with protocol esp, it will be treated as ESP payload
-C calgo [-R]
Specify compression algorithm. If -R is not speci-
fied with ipcomp line, the kernel will use well-known
IPComp CPI (compression parameter index) on IPComp
CPI field on packets, and spi field will be ignored.
spi field is only for kernel internal use in this
case. If -R is used, the value on spi field will
appear on IPComp CPI field on outgoing packets. spi
field needs to be smaller than 0x10000 in this case.
protocol esp accepts -E and -A. protocol esp-old accepts -E
only. protocol ah and ah-old accept -A only. protocol ipcomp
accepts -C only.
key must be double-quoted character string or series of hexadeci-
Possible values for ealgo, aalgo and calgo are specified in sepa-
These are selections of the secure communication specified as
IPv4/v6 address or IPv4/v6 address range, and it may accompany
TCP/UDP port specification. This takes the following form:
prefixlen and port must be decimal number. The square bracket
around port is really necessary. They are not manpage metachar-
The setkey utility does not consult hostname-to-address for argu-
ments src and dst. They must be in numeric form.
Upper-layer protocol to be used. You can use one of words in
/etc/protocols as upperspec. Or icmp6, ip4, and any can be spec-
ified. any stands for ``any protocol''. Also you can use the
NOTE: upperspec does not work against forwarding case at this
moment, as it requires extra reassembly at forwarding node (not
implemented at this moment). We have many protocols in
/etc/protocols, but protocols except of TCP, UDP and ICMP may not
be suitable to use with IPsec. You have to consider and be care-
ful to use them. icmp tcp udp all protocols
policy policy is the one of following:
-P direction discard
-P direction none
-P direction ipsec protocol/mode/src-dst/level
You must specify the direction of its policy as direction.
Either out or in are used. discard means the packet matching
indexes will be discarded. none means that IPsec operation will
not take place onto the packet. ipsec means that IPsec operation
will take place onto the packet. Either ah, esp or ipcomp is to
be set as protocol. mode is either transport or tunnel. If mode
is tunnel, you must specify the end-points addresses of the SA as
src and dst with `-' between these addresses which is used to
specify the SA to use. If mode is transport, both src and dst
can be omitted. level is to be one of the following: default,
use, require or unique. If the SA is not available in every
level, the kernel will request getting SA to the key exchange
daemon. default means the kernel consults to the system wide
default against protocol you specified, e.g. esp_trans_deflev
sysctl variable, when the kernel processes the packet. use means
that the kernel use a SA if it's available, otherwise the kernel
keeps normal operation. require means SA is required whenever
the kernel sends a packet matched with the policy. unique is the
same to require. In addition, it allows the policy to bind with
the unique out-bound SA. If you use the SA by manual keying, you
can put the decimal number as the policy identifier after unique
separated by colon `' like the following; unique:number. number
must be between 1 and 32767. It corresponds to extensions -u.
Note that ``discard'' and ``none'' are not in the syntax
described in ipsec_set_policy(3). There are little differences
in the syntax. See ipsec_set_policy(3) for detail.
The following list shows the supported algorithms. protocol and
algorithm are almost orthogonal. Followings are the list of authentica-
tion algorithms that can be used as aalgo in -A aalgo of protocol parame-
algorithm keylen (bits) comment
hmac-md5 128 ah: rfc2403
128 ah-old: rfc2085
hmac-sha1 160 ah: rfc2404
160 ah-old: 128bit ICV (no document)
keyed-md5 128 ah: 96bit ICV (no document)
128 ah-old: rfc1828
keyed-sha1 160 ah: 96bit ICV (no document)
160 ah-old: 128bit ICV (no document)
null 0 to 2048 for debugging
hmac-sha2-256 256 ah: 96bit ICV (no document)
256 ah-old: 128bit ICV (no document)
hmac-sha2-384 384 ah: 96bit ICV (no document)
384 ah-old: 128bit ICV (no document)
hmac-sha2-512 512 ah: 96bit ICV (no document)
512 ah-old: 128bit ICV (no document)
tcp-md5 8 to 640 tcp: rfc2385
Followings are the list of encryption algorithms that can be used as
ealgo in -E ealgo of protocol parameter:
algorithm keylen (bits) comment
des-cbc 64 esp-old: rfc1829, esp: rfc2405
3des-cbc 192 rfc2451
simple 0 to 2048 rfc2410
blowfish-cbc 40 to 448 rfc2451
cast128-cbc 40 to 128 rfc2451
des-deriv 64 ipsec-ciph-des-derived-01 (expired)
3des-deriv 192 no document
rijndael-cbc 128/192/256 draft-ietf-ipsec-ciph-aes-cbc-00
Followings are the list of compression algorithms that can be used as
calgo in -C calgo of protocol parameter:
add 2001:db8:4819::1 2001:db8:481d::1 esp 123457
-E des-cbc "ESP SA!!" ;
add 2001:db8:4819::1 2001:db8:481d::1 ah 123456
-A hmac-sha1 "AH SA configuration!" ;
add 10.0.11.41 10.0.11.33 esp 0x10001
-E des-cbc "ESP with"
-A hmac-md5 "authentication!!" ;
get 2001:db8:4819::1 2001:db8:481d::1 ah 123456 ;
dump esp ;
spdadd 10.0.11.41/32 10.0.11.33/32[any] any
-P out ipsec esp/tunnel/192.168.0.1-192.168.1.2/require ;
add 10.1.10.34 10.1.10.36 tcp 0x1000 -A tcp-md5 "TCP-MD5 BGP secret" ;
The command exits with 0 on success, and non-zero on errors.
ipsec_set_policy(3), racoon(8), sysctl(8)
The setkey utility first appeared in WIDE Hydrangea IPv6 protocol stack
kit. The command was completely re-designed in June 1998.
DragonFly 3.7 November 20, 2000 DragonFly 3.7