DragonFly On-Line Manual Pages
RUE(4) DragonFly Kernel Interfaces Manual RUE(4)
rue -- RealTek RTL8150 USB to Fast Ethernet controller driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The rue driver provides support for USB Ethernet adapters based on the
RealTek RTL8150 USB to Fast Ethernet controller chip.
The RTL8150 contains an integrated Fast Ethernet MAC, which supports both
10 and 100Mbps speeds in either full or half duplex. Although designed
to interface with 100Mbps peripheral, the existing USB standard specifies
a maximum transfer speed of 12Mbps. Users should therefore not expect to
actually achieve 100Mbps speeds with this device.
The rue driver supports the following media types:
autoselect Enable auto selection of the media type and options. The
user can manually override the auto selected mode by adding
media options to the /etc/rc.conf file.
10baseT/UTP Set 10Mbps operation. The mediaopt option can also be used
to select either full-duplex or half-duplex modes.
100baseTX Set 100Mbps (Fast Ethernet) operation. The mediaopt option
can also be used to select either full-duplex or half-duplex
The rue driver supports the following media options:
full-duplex Force full duplex operation.
half-duplex Force half duplex operation.
For more information on configuring this device, see ifconfig(8).
The rue driver supports RealTek RTL8150 based USB Ethernet adapters
* Buffalo (Melco Inc.) LUA-KTX
* Green House GH-USB100B
* LinkSys USB100M
* Billionton 10/100 FastEthernet USBKR2
rue%d: watchdog timeout A packet was queued for transmission and a
transmit command was issued, however the device failed to acknowledge the
transmission before a timeout expired.
rue%d: rx list init failed The driver failed to allocate an mbuf for the
rue%d: no memory for rx list The driver failed to allocate an mbuf for
the receiver ring.
arp(4), ifmedia(4), miibus(4), netintro(4), ng_ether(4), ifconfig(8)
ReakTek RTL8150 data sheet,
The rue device driver first appeared in FreeBSD 5.1.
The rue driver was written by Shunsuke Akiyama <akiyama@FreeBSD.org>.
DragonFly 4.1 July 16, 2005 DragonFly 4.1