DragonFly On-Line Manual Pages
RSHD(8) DragonFly System Manager's Manual RSHD(8)
rshd -- remote shell server
The rshd server is the server for the rcmd(3) routine and, consequently,
for the rsh(1) program. The server provides remote execution facilities
with authentication based on privileged port numbers from trusted hosts.
The rshd server listens for service requests at the port indicated in the
``cmd'' service specification; see services(5). When a service request
is received the following protocol is initiated:
1. The server checks the client's source port. If the port is not in
the range 512-1023, the server aborts the connection.
2. The server reads characters from the socket up to a NUL (`\0') byte.
The resultant string is interpreted as an ASCII number, base 10.
3. If the number received in step 2 is non-zero, it is interpreted as
the port number of a secondary stream to be used for the stderr. A
second connection is then created to the specified port on the
client's machine. The source port of this second connection is also
in the range 512-1023.
4. The server checks the client's source address and requests the cor-
responding host name (see gethostbyaddr(3), hosts(5) and named(8)).
If the hostname cannot be determined or the hostname and address do
not match after verification, the dot-notation representation of the
host address is used.
5. A null terminated user name of at most 16 characters is retrieved on
the initial socket. This user name is interpreted as the user iden-
tity on the client's machine.
6. A null terminated user name of at most 16 characters is retrieved on
the initial socket. This user name is interpreted as a user iden-
tity to use on the server's machine.
7. A null terminated command to be passed to a shell is retrieved on
the initial socket. The length of the command is limited by the
upper bound on the size of the system's argument list.
8. Rshd then validates the user using ruserok(3), which uses the file
/etc/hosts.equiv and the .rhosts file found in the user's home
directory. The -l option prevents ruserok(3) from doing any valida-
tion based on the user's .rhosts file, unless the user is the supe-
9. If the file /var/run/nologin exists and the user is not the supe-
ruser, the connection is closed. The name of the nologin file may
be overridden using the nologin capability in /etc/login.conf
according to the local user's login class, which may also be used to
restrict rsh(1) access by login time (times.allow and times.deny
capabilities) and remote host (hosts.allow and hosts.deny capabili-
10. A NUL byte is returned on the initial socket and the command line is
passed to the normal login shell of the user. The shell inherits
the network connections established by rshd.
The options are as follows:
-? Display the usage message, and exit.
-D Sets the TCP_NODELAY socket option, which improves the perfor-
mance of small back-to-back writes at the expense of additional
-L Causes all successful accesses to be logged to syslogd(8) as
-a This flag is ignored, and is present for compatibility purposes.
-l Do not use the user's .rhosts file for authentication, unless the
user is the superuser.
-n Turn off transport level keepalive messages. This will prevent
sessions from timing out if the client crashes or becomes
Except for the last one listed below, all diagnostic messages are
returned on the initial socket, after which any network connections are
closed. An error is indicated by a leading byte with a value of 1 (0 is
returned in step 10 above upon successful completion of all the steps
prior to the execution of the login shell).
Locuser too long.
The name of the user on the client's machine is longer than 16
Ruser too long.
The name of the user on the remote machine is longer than 16
Command too long.
The command line passed exceeds the size of the argument list (as
configured into the system).
No password file entry for the user name existed or the authenti-
cation procedure described above failed.
The chdir(2) function to the home directory failed.
Logins not available right now.
Rsh(1) was attempted outside the allowed hours defined in
/etc/login.conf for the local user's login class.
Can't make pipe.
The pipe needed for the stderr, wasn't created.
Can't fork; try again.
A fork(2) by the server failed.
The user's login shell could not be started. This message is
returned on the connection associated with the stderr, and is not
preceded by a flag byte.
rlogin(1), rsh(1), gethostbyaddr(3), rcmd(3), ruserok(3), auth.conf(5),
hosts(5), hosts.equiv(5), login.conf(5), nologin(5), services(5),
named(8), rlogind(8), syslogd(8)
IPv6 support was added by WIDE/KAME project.
The authentication procedure used here assumes the integrity of each
client machine and the connecting medium. This is insecure, but is use-
ful in an ``open'' environment.
A facility to allow all data exchanges to be encrypted should be present.
A more extensible protocol (such as Telnet) should be used.
DragonFly 3.5 June 4, 1993 DragonFly 3.5