DragonFly On-Line Manual Pages
RESIDENT(8) DragonFly System Manager's Manual RESIDENT(8)
resident -- Make a dynamic binary resident
resident [-l] [-f] [-x id] [-d] [-R] program ...
The resident utility may be used to make a dynamic binary memory-resi-
dent. This works by running the binary just past its DLL mmap's and
relocation and then making a copy of its vmspace. The copy is registered
in the kernel and later exec's of the program will cause a copy of the
copy to be used. When ld-elf.so detects that it is running resident, it
skips all initial library loads (because they are already loaded).
Care must be taken when using this program. It is recommended that you
delete all resident registrations when updating the system shared
libraries and binaries.
The following options are available:
-l List binaries that are currently memory-resident.
-f Force mode, even if the binary does not appear to be a dynamic
binary. This way you can run resident through statically com-
piled wrappers. The first dynamic binary encountered in the exec
chain will be operated on.
-x id Delete a registration by id.
-d Delete a registration by program name. If neither of the above
two options are specified a new registration is created.
-R Delete all registrations in the kernel.
ld(1), ldd(1), nm(1), rtld(1), resident.conf(5)
The resident program, its kernel supplement and this manual page were
written by Matthew Dillon <firstname.lastname@example.org>.
DragonFly 4.1 May 21, 2003 DragonFly 4.1