DragonFly On-Line Manual Pages
QUOTACHECK(8) DragonFly System Manager's Manual QUOTACHECK(8)
quotacheck -- file system quota consistency checker
quotacheck [-g] [-u] [-v] filesystem file ...
quotacheck [-g] [-u] [-v] -a
The quotacheck utility examines each file system, builds a table of cur-
rent disk usage, and compares this table against that recorded in the
disk quota file for the file system. If any inconsistencies are
detected, both the quota file and the current system copy of the incor-
rect quotas are updated (the latter only occurs if an active file system
is checked). By default both user and group quotas are checked.
The following options are available:
-a If supplied in place of any file system names, quotacheck will
check all the file systems indicated in /etc/fstab to be read-
write with disk quotas. By default only the types of quotas
listed in /etc/fstab are checked.
-g Only group quotas listed in /etc/fstab are to be checked.
-u Only user quotas listed in /etc/fstab are to be checked.
-v Report discrepancies between the calculated and recorded disk
quotas and other additional diagnostic messages.
Specifying both -g and -u is equivalent to the default. Parallel passes
are run on the file systems required, using the pass numbers in
/etc/fstab in an identical fashion to fsck(8).
Normally, quotacheck operates silently.
The quotacheck utility expects each file system to be checked to have a
quota files named quota.user and quota.group which are located at the
root of the associated file system. These defaults may be overridden in
/etc/fstab. If a file is not present, quotacheck will create it. These
files should be edited with the edquota(8) utility.
The quotacheck utility is normally run at boot time from the /etc/rc
file. The rc startup procedure is controlled by the /etc/rc.conf vari-
able check_quotas. Note that to enable this functionality in /etc/rc you
also need to enable startup quota procedures with the variable
enable_quotas in /etc/rc.conf.
The quotacheck utility accesses the raw device in calculating the actual
disk usage for each user. Thus, the file systems checked should be qui-
escent while quotacheck is running.
quota.user at the file system root with user quotas
quota.group at the file system root with group quotas
/etc/fstab default file systems
quota(1), quotactl(2), fstab(5), edquota(8), fsck(8), quotaon(8),
The quotacheck utility appeared in 4.2BSD.
DragonFly 4.3 June 5, 1993 DragonFly 4.3