DragonFly On-Line Manual Pages
POWERD(8) DragonFly System Manager's Manual POWERD(8)
powerd -- simple ACPI based CPU/power control
powerd [-dt] [-p hysteresis] [-u trigger_up] [-r poll_time]
The powerd daemon monitors the CPU load and automatically adjusts the CPU
frequency up or down.
All CPUs will be set to their maximum frequency when the 1 second machine
load exceeds 25% of one CPU. All CPUs will be set to their minimum fre-
quency when the 10 second machine load drops below 12% of one CPU.
The options are as follows:
-d Debug option. Causes powerd to not go to the background
and prints some debug output to stdout.
-p hysteresis Percent of the upper limit to subtract as an hysteresis
value to scale down to the min frequency. The default is
10 (meaning 10%).
-t Turbo mode. Disables switching to turbo mode as maximum
frequency completely. Switching to turbo mode as maximum
frequency is enabled by default, if the CPU supports it.
-u trigger_up Per CPU load limit in percent to force maximum frequency.
The default is 25 (meaning an instantanious load of 0.25
on a single cpu). The load is calculated over 3 polls.
It is suggested that this value not be made lower than
-r poll_time Polling time in seconds. Default is 1.0. Setting this
value lower will poll for load changes faster. For exam-
ple, a workstation might want to use 0.2 or 0.4. can
become unstable if you make this value too small.
Total sample interval in seconds. Default is 8.0. This
effects how quickly powerd ratchets down the frequency and
cpus on an idle machine. Longer times will ratchet down
more slowly. For example, a workstation might want to use
a value of 30.0.
The defaults work well for servers but a workstation user might want to
use something like the following in their /etc/rc.conf to ratchet up the
machine more quickly in response to spike loads (such as when you are
powerd_flags="-u 7 -r 0.2 -T 60"
The powerd utility will exit with a non-zero code if the required sysctls
are not present.
acpi(4), est(4), powernow(4)
The powerd command first appeared in DragonFly 2.7.
I'm shocked I tell you, shocked that there might be bugs in this program!
DragonFly 4.1 October 28, 2014 DragonFly 4.1