DragonFly On-Line Manual Pages
NTPD(8) DragonFly System Manager's Manual NTPD(8)
ntpd -- Network Time Protocol daemon
ntpd [-dnSsv] [-f file] [-p file]
The ntpd daemon synchronizes the local clock to one or more remote NTP
servers or local timedelta sensors. ntpd can also act as an NTP server
itself, redistributing the local time. It implements the Simple Network
Time Protocol version 4, as described in RFC 5905, and the Network Time
Protocol version 3, as described in RFC 1305.
The options are as follows:
-d Do not daemonize. If this option is specified, ntpd will run
in the foreground and log to stderr.
-f file Use file as the configuration file, instead of the default
-n Configtest mode. Only check the configuration file for
-p file Write pid to file
-S Do not set the time immediately at startup. This is the
-s Try to set the time immediately at startup, as opposed to
slowly adjusting the clock. ntpd will stay in the foreground
for up to 15 seconds waiting for one of the configured NTP
servers to reply.
-v This option allows ntpd to send DEBUG priority messages to
ntpd uses the adjtime(2) system call to correct the local system time
without causing time jumps. Adjustments of 32ms and greater are logged
using syslog(3). The threshold value is chosen to avoid having local
clock drift thrash the log files. Should ntpd be started with the -d or
-v option, all calls to adjtime(2) will be logged.
After the local clock is synchronized, ntpd adjusts the clock frequency
using the ntp_adjtime(2) system call to compensate for systematic drift.
ntpd is usually started at boot time, and can be enabled by setting
openntpd_flags in /etc/rc.conf. See rc(8) and rc.conf(5) for more infor-
mation on the boot process and enabling daemons.
When ntpd starts up, it reads settings from its configuration file, typi-
cally ntpd.conf(5), and its initial clock drift from /var/db/ntpd.drift.
Clock drift is periodically written to the drift file thereafter.
When ntpd (engine) receives a SIGINFO signal (or a SIGUSR1 signal on sys-
tems without SIGINFO), it writes its peer and sensor status to syslog(3).
/usr/local/etc/ntpd.conf Default configuration file.
/var/db/ntpd.drift Drift file.
/var/run/ntpd.sock Socket file for communication with
date(1), adjtime(2), ntp_adjtime(2), ntpd.conf(5), rc.conf(5), ntpctl(8),
David L. Mills, Network Time Protocol (Version 3): Specification,
Implementation and Analysis, RFC 1305, March 1992.
David L. Mills, Jim Martin, Jack Burbank, and William Kasch, Network Time
Protocol Version 4: Protocol and Algorithms Specification, RFC 5905, June
The ntpd program first appeared in OpenBSD 3.6.
DragonFly 4.1 October 4, 2013 DragonFly 4.1