DragonFly On-Line Manual Pages
NGHOOK(8) DragonFly System Manager's Manual NGHOOK(8)
nghook -- connect to a netgraph(4) node
nghook [-a] [-d] path [hookname]
nghook creates a ng_socket(4) socket type node and connects it to hook
hookname of the node found at path. If hookname is omitted, ``debug'' is
At this point all data written to standard input is sent to the node and
all data received from the node is relayed to standard output.
The options are as follows:
-a Output each read packet in ASCII.
-d Increase the debugging verbosity level.
netgraph(3), netgraph(4), ngctl(8)
The netgraph system was designed and first implemented at Whistle Commu-
nications, Inc. in a version of FreeBSD 2.2 customized for the Whistle
Archie Cobbs <firstname.lastname@example.org>
Although all input is read in unbuffered mode, there's no way to control
the packetization of the input.
DragonFly 3.7 January 19, 1999 DragonFly 3.7