DragonFly On-Line Manual Pages
NGCTL(8) DragonFly System Manager's Manual NGCTL(8)
ngctl -- netgraph control utility
ngctl [-d] [-f filename] [-n nodename] [command ...]
The ngctl utility creates a new netgraph node of type socket which can be
used to issue netgraph commands. If no -f flag is given, no command is
supplied on the command line, and standard input is a tty, ngctl will
enter interactive mode. Otherwise ngctl will execute the supplied com-
mand(s) and exit immediately.
Nodes can be created, removed, joined together, etc. ASCII formatted
control messages can be sent to any node if that node supports
binary/ASCII control message conversion.
In interactive mode, ngctl will display any control messages and data
packets received by the socket node. In the case of control messages,
the message arguments are displayed in ASCII form if the originating node
The options are as follows:
Read commands from the named file. A single dash represents the
standard input. Blank lines and lines starting with a ``#'' are
Assign nodename to the newly created netgraph node. The default
name is ngctlXXX where XXX is the process ID number.
-d Increase the debugging verbosity level.
The currently supported commands in ngctl are:
connect Connects two nodes
debug Get/set debugging verbosity level
help Show command summary or get help on a command
list Show information about all nodes
mkpeer Create and connect a new node to an existing node
msg Send an ASCII formatted message to a node
name Assign a name to a node
read Read and execute commands from a file
rmhook Disconnect a node's hook
show Show information about a node
shutdown Shutdown a node
status Get human readable status from a node
types Show all installed node types
write Send a data packet down the hook named by "hook".
quit Exit program
Some commands have aliases, e.g., ``ls'' is the same as ``list''. The
``help'' command displays the available commands, their usage and
aliases, and a brief description.
The ngctl utility exits 0 on success, and >0 if an error occurs.
netgraph(3), netgraph(4), nghook(8)
The netgraph system was designed and first implemented at Whistle Commu-
nications, Inc. in a version of FreeBSD 2.2 customized for the Whistle
Archie Cobbs <firstname.lastname@example.org>
DragonFly 3.7 January 19, 1999 DragonFly 3.7