DragonFly On-Line Manual Pages
NG_RFC1490(4) DragonFly Kernel Interfaces Manual NG_RFC1490(4)
ng_rfc1490 -- RFC 1490 netgraph node type
The rfc1490 node type performs protocol encapsulation, de-encapsulation,
and multiplexing according to RFC 1490 (which has since been updated by
RFC 2427). This particular type of encapsulation is often used on top of
frame relay DLCI channels.
The downstream hook is used to transmit and receive encapsulated frames.
On the other side of the node, the inet and ppp hooks are used to trans-
mit and receive raw IP frames and PPP frames, respectively. PPP frames
are transmitted and received according to RFC 1973; in particular, frames
appearing on the ppp hook begin with the PPP protocol number.
Typically the inet hook is connected to the inet hook of an ng_iface(4)
This node type supports the following hooks:
downstream Connects to the RFC 1490 peer entity.
inet Transmits and receives raw IP frames.
ppp Transmits and receives PPP frames.
This node type only supports the generic control messages.
This node shuts down upon receipt of a NGM_SHUTDOWN control message, or
when all hooks have been disconnected.
netgraph(4), ng_frame_relay(4), ng_iface(4), ngctl(8)
C. Brown and A. Malis, Multiprotocol Interconnect over Frame Relay, RFC
W. Simpson, PPP in Frame Relay, RFC 1973.
The ng_rfc1490 node type was implemented in FreeBSD 4.0.
Julian Elischer <julian@FreeBSD.org>
Not all of RFC 1490 is implemented.
DragonFly 4.1 January 19, 1999 DragonFly 4.1