DragonFly On-Line Manual Pages
NATACONTROL(8) DragonFly System Manager's Manual NATACONTROL(8)
natacontrol -- NATA device driver control program
natacontrol <command> args
natacontrol attach channel
natacontrol detach channel
natacontrol reinit channel
natacontrol create type [interleave] disk0 ... diskN
natacontrol delete raid
natacontrol addspare raid disk
natacontrol rebuild raid
natacontrol status raid
natacontrol mode device
natacontrol info channel
natacontrol cap device
natacontrol feature device acoustic soundsupplevel
natacontrol feature device apm apmlevel
The natacontrol utility is a control program that provides the user
access and control to the DragonFly nata(4) subsystem.
The natacontrol utility can cause severe system crashes and loss of data
if used improperly. Please exercise caution when using this command!
The channel argument is the ATA channel device (e.g., ata0) on which to
operate. The following commands are supported:
attach Attach an ATA channel. Devices on the channel are probed and
attached as is done on boot.
detach Detach an ATA channel. Devices on the channel are removed from
the kernel, and all outstanding transfers etc. are returned back
to the system marked as failed.
reinit Reinitialize an ATA channel. Both devices on the channel are
reset and initialized to the parameters the ATA driver has
stored internally. Devices that have gone bad and no longer
respond to the probe, or devices that have physically been
removed, are removed from the kernel. Likewise are devices that
show up during a reset, probed and attached.
create Create a type ATA RAID. The type can be RAID0 (stripe), RAID1
(mirror), RAID0+1, SPAN or JBOD. In case the RAID has a RAID0
component, the interleave must be specified in number of sec-
tors. The RAID will be created of the individual disks named
disk0 ... diskN.
Although the nata(4) driver allows for creating an ATA RAID on
disks with any controller, there are restrictions. It is only
possible to boot on an array if it is either located on a
``real'' ATA RAID controller like the Promise or Highpoint con-
trollers, or if the RAID declared is of RAID1 or SPAN type; in
case of a SPAN, the partition to boot must reside on the first
disk in the SPAN.
delete Delete a RAID array on a RAID capable ATA controller.
Add a spare disk to an existing RAID.
rebuild Rebuild a RAID1 array on a RAID capable ATA controller.
status Get the status of an ATA RAID.
mode Without the mode argument, the current transfer modes of the
device are printed. If the mode argument is given, the nata(4)
driver is asked to change the transfer mode to the one given.
The nata(4) driver will reject modes that are not supported by
the hardware. Modes are given like ``PIO3'', ``udma2'',
``udma100'', case does not matter.
Currently supported modes are: PIO0, PIO1, PIO2, PIO3, PIO4,
WDMA2, UDMA2 (alias UDMA33), UDMA4 (alias UDMA66), UDMA5 (alias
UDMA100) and UDMA6 (alias UDMA133). The device name and manu-
facture/version strings are shown.
cap Show detailed info about the device on device.
feature Set disk drive features. Currently, acoustic and apm features
Controls the disk drive Acoustic Management level.
The soundsupplevel may be set to off which will turn
off acoustic management, maxperf to optimize for maxi-
mum performance, maxquiet to optimize for maximum
quiet, or a numeric level from 0 to 124. The higher
the numeric level, the higher the theoretical sound
level emitted from the drive. Note that few devices
support this command and even fewer will allow the
range of levels supported.
Sets the disk drive Advanced Power Management (APM)
level. This command is generally used on laptop
(notebook) hard disks to control the power level con-
sumed by the drive (at the expense of performance).
The apmlevel may be set to one of: off (turn off APM),
maxperf or minpower (optimize for maximum performance
or minimum power, respectively), or a numeric level
which can be 0 to 127 inclusive indicating an increas-
ing level of performance over power savings. The
numeric levels may be prefixed by s which will allow
the drive to include suspension as part of the power
savings. Note that not all hard drives will support
the off command, and that the number of incremental
power savings levels do not typically have as wide of
a range as this command will support.
info Show info about the attached devices on the channel.
list Show info about all attached devices on all active controllers.
To get information on devices attached to a channel, use the command
natacontrol info ata0
To see the devices' current access modes, use the command line:
natacontrol mode ad0
which results in the modes of the devices being displayed as a string
current mode = UDMA100
You can set the mode with natacontrol and a string like the above, for
natacontrol mode ad0 PIO4
The new modes are set as soon as the natacontrol command returns.
The natacontrol utility first appeared in FreeBSD 4.6 and was imported
into DragonFly 1.7.
The natacontrol utility was written by Soren Schmidt <sos@FreeBSD.org>.
This manual page was written by Soren Schmidt <sos@FreeBSD.org>.
DragonFly 4.1 March 23, 2013 DragonFly 4.1