DragonFly On-Line Manual Pages
MTIO(4) DragonFly Kernel Interfaces Manual MTIO(4)
mtio -- magtape interface
The special files named /dev/[nr]sa* refer to SCSI tape drives, which may
be attached to the system. /dev/[nr]sa*.ctl are control devices that can
be used to issue ioctls to the SCSI tape driver to set parameters that
are required to last beyond the unmounting of a tape.
The rewind devices automatically rewind when the last requested read,
write or seek has finished, or the end of the tape has been reached. The
letter `n' is usually prepended to the name of the no-rewind devices.
Tapes can be written with either fixed length records or variable length
records. See sa(4) for more information. Two end-of-file markers mark
the end of a tape, and one end-of-file marker marks the end of a tape
file. If the tape is not to be rewound it is positioned with the head in
between the two tape marks, where the next write will over write the sec-
ond end-of-file marker.
All of the magtape devices may be manipulated with the mt(1) command.
A number of ioctl(2) operations are available on raw magnetic tape. Con-
sult <sys/mtio.h> for further information.
mt(1), tar(1), sa(4)
The mtio manual appeared in 4.2BSD. An i386 version first appeared in
The status should be returned in a device independent format.
The special file naming should be redone in a consistent and understand-
DragonFly 4.1 March 5, 2005 DragonFly 4.1