DragonFly On-Line Manual Pages
MFI(4) DragonFly Kernel Interfaces Manual MFI(4)
mfi -- LSI MegaRAID SAS driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
This driver is for LSI's next generation PCI Express SAS RAID con-
trollers. Access to RAID arrays (logical disks) from this driver is pro-
vided via /dev/mfid? and access to JBOD disks is provided via
/dev/mfisyspd? device nodes. A simple management interface is also pro-
vided on a per-controller basis via the /dev/mfi? device node.
The mfi name is derived from the phrase "MegaRAID Firmware Interface",
which is substantially different than the old "MegaRAID" interface and
thus requires a new driver.
Older SCSI and SATA MegaRAID cards are supported by amr(4) and will not
work with this driver. Likewise, newer LSI MegaRAID SAS controllers are
supported by mrsas(4) and will not work with this driver.
3 Gb/s and 6 Gb/s support both initiator target (IT) and integrated RAID
(IR) firmware (see http://kb.lsi.com/KnowledgebaseArticle16266.aspx).
The mfi driver supports controllers with an IR image. At least some
cards (such as the IBM ServeRAID M1015) will attach to the mps(4) driver
when IT firmware is used.
Two sysctls are provided to tune the mfi driver's behavior when a request
is made to remove a mounted volume. By default the driver will disallow
any requests to remove a mounted volume. If the sysctl
dev.mfi.%d.delete_busy_volumes is set to 1, then the driver will allow
mounted volumes to be removed.
By default, the driver will use MSI if it is supported. This
behavior can be turned off by setting this tunable to 0.
See description above.
The mfi driver supports the following hardware:
* LSI MegaRAID SAS 1078
* LSI MegaRAID SAS 8408E
* LSI MegaRAID SAS 8480E
* LSI MegaRAID SAS 9240-4i
* LSI MegaRAID SAS 9240-8i
* LSI MegaRAID SAS 9260-4i
* LSI MegaRAID SAS 9260-8i
* LSI MegaRAID SAS 9260DE-8i
* LSI MegaRAID SAS 9260-16i
* LSI MegaRAID SAS 9261-8i
* LSI MegaRAID SAS 9280-4i4e
* LSI MegaRAID SAS 9280-8e
* LSI MegaRAID SAS 9280DE-8e
* LSI MegaRAID SAS 9280-16i4e
* LSI MegaRAID SAS 9280-24i4e
* Dell PERC5
* Dell PERC6
* Dell PERC H710 Embedded
* Dell PERC H710 Adapter
* Dell PERC H710 Mini (blades)
* Dell PERC H710 Mini (monolithics)
* Dell PERC H710P Adapter
* Dell PERC H710P Mini (blades)
* Dell PERC H710P Mini (monolithics)
* Dell PERC H810 Adapter
* IBM ServeRAID M1015 SAS/SATA
* IBM ServeRAID M5015 SAS/SATA
* IBM ServeRAID-MR10i
* Intel RAID Controller SROMBSAS18E
* Intel RAID Controller RS25DB080
* Intel RAID Controller RS25NB008
/dev/mfid? array/logical disk interface
/dev/mfisyspd? JBOD disk interface
/dev/mfi? management interface
mfid%d: Unable to delete busy device An attempt was made to remove a
mfisyspd%d: Unable to delete busy device dito for JBOD disks
amr(4), mps(4), mrsas(4), pci(4), mfiutil(8)
The mfi driver first appeared in FreeBSD 6.1.
The mfi driver and this manual page were written by Scott Long
DragonFly 3.9 July 18, 2014 DragonFly 3.9