DragonFly On-Line Manual Pages
MEM(4) DragonFly Kernel Interfaces Manual MEM(4)
mem, kmem -- memory files
The special file /dev/mem is an interface to the physical memory of the
computer. Byte offsets in this file are interpreted as physical memory
addresses. Reading and writing this file is equivalent to reading and
writing memory itself. Only offsets within the bounds of /dev/mem are
Kernel virtual memory is accessed through the interface /dev/kmem in the
same manner as /dev/mem. Only kernel virtual addresses that are cur-
rently mapped to memory are allowed.
On ISA the I/O memory space begins at physical address 0x000a0000 and
runs to 0x00100000. The per-process data size for the current process is
UPAGES long, and ends at virtual address 0xf0000000.
Several architectures allow attributes to be associated with ranges of
physical memory. These attributes can be manipulated via ioctl() calls
performed on /dev/mem. Declarations and data types are to be found in
The specific attributes, and number of programmable ranges may vary
between architectures. The full set of supported attributes is:
The region is not cached.
Writes to the region may be combined or performed out of order.
Writes to the region are committed synchronously.
Writes to the region are committed asynchronously.
The region cannot be written to.
Memory ranges are described by struct mem_range_desc:
u_int64_t mr_base; /* physical base address */
u_int64_t mr_len; /* physical length of region */
int mr_flags; /* attributes of region */
In addition to the region attributes listed above, the following flags
may also be set in the mr_flags field:
The region's base address cannot be changed.
The region's length cannot be changed.
The region is believed to have been established by the system
The region is currently active.
We believe the region to be invalid or otherwise erroneous.
The region cannot be disabled.
The region is currently owned by another process and may not be
Operations are performed using struct mem_range_op:
struct mem_range_desc *mo_desc;
The MEMRANGE_GET ioctl is used to retrieve current memory range
attributes. If mo_arg is set to 0, it will be updated with the total
number of memory range descriptors. If greater than 0, the array at
mo_desc will be filled with a corresponding number of descriptor struc-
tures, or the maximum, whichever is less.
The MEMRANGE_SET ioctl is used to add, alter and remove memory range
attributes. A range with the MDF_FIXACTIVE flag may not be removed; a
range with the MDF_BUSY flag may not be removed or updated.
mo_arg should be set to MEMRANGE_SET_UPDATE to update an existing or
establish a new range, or to MEMRANGE_SET_REMOVE to remove a range.
[EOPNOTSUPP] Memory range operations are not supported on this
[ENXIO] No memory range descriptors are available (eg.
firmware has not enabled any).
[EINVAL] The memory range supplied as an argument is invalid or
overlaps another range in a fashion not supported by
[EBUSY] An attempt to remove or update a range failed because
the range is busy.
[ENOSPC] An attempt to create a new range failed due to a
shortage of hardware resources (eg. descriptor slots).
[ENOENT] An attempt to remove a range failed because no range
matches the descriptor base/length supplied.
[EPERM] An attempt to remove a range failed because the range
is permanently enabled.
The mem and kmem files appeared in Version 6 AT&T UNIX. The ioctl inter-
face for memory range attributes was added in FreeBSD 3.2.
Busy range attributes are not yet managed correctly.
DragonFly 3.9 May 2, 1991 DragonFly 3.9