DragonFly On-Line Manual Pages

Search: Section:  


MAKE.CONF(5)             DragonFly File Formats Manual            MAKE.CONF(5)

NAME

make.conf - system build information

DESCRIPTION

The file make.conf contains settings that control the compilation of the DragonFly sources. The file make.conf is generally created by the system administrator when the values need to be changed from their defaults. The purpose of make.conf is not to run commands or perform compilation actions directly. Instead, it is included by the various makefiles in /usr/src which conditionalize their internal actions according to the settings found there. The /etc/make.conf file is included from the appropriate Makefile which specifies the default settings for all the available options. Options need only be specified in /etc/make.conf when the system administrator wishes to override these defaults. The build procedures occur in three areas: world, kernel, and documentation. Variables set in make.conf may be applicable during builds in one, two, or all of these areas. They may be specified for a particular build via the -D option of make(1). The following lists provide a name and short description for each variable you can use during the indicated builds. The values of variables flagged as bool are ignored; the variable being set at all (even to "FALSE" or "NO") causes it to be treated as if it were set. The following list provides a name and short description for variables that are used for all builds, or are used by the makefiles for things other than builds. CPUTYPE (str) Controls which processor should be targeted for generated code. This controls processor-specific optimizations in certain code (currently only OpenSSL) as well as modifying the value of CFLAGS and COPTFLAGS to contain the appropriate optimization directive to gcc(1). The automatic setting of CFLAGS and COPTFLAGS may be overridden using the NO_CPU_CFLAGS and NO_CPU_COPTFLAGS variables, respectively. Refer to /usr/share/examples/etc/defaults/make.conf for a list of recognized CPUTYPE options. CCVER (str) Controls which GCC version to use by default. It should be set as CCVER?= so as not to interfere with overrides from userland. We currently recommend that an override NOT be set in /etc/make.conf. Currently accepted values for compilers which are part of DragonFly are "gcc47" and "gcc80" (default). All other values will handled according to the settings in compilers.conf(5). WORLD_CCVER (str) Controls which version of GCC builds the base system, including the kernel. "gcc80" is the default value. LDVER (str) Controls which linker to use by default. Currently accepted values are "ld.gold" (GNU gold linker, default) and "ld.bfd" (classic GNU ld linker). WORLD_LDVER (str) Controls which linker builds the base system, including the kernel. "ld.gold" is the default value. BINUTILSVER (str) Controls which binutils to use by default. Currently accepted values are "binutils227" and "binutils234" (default). WORLD_BINUTILSVER (str) Controls which version of binutils builds the base system, including the kernel. "binutils234" is the default value. WORLD_CFLAGS (str) Controls the compiler setting when compiling C code. Optimization levels are controlled by WORLD_CCOPTLEVEL. BDECFLAGS is provided as a set of gcc(1) settings suggested by Bruce Evans <bde@FreeBSD.org> for developing and testing changes. They can be used safely, if set, by: WORLD_CFLAGS+=${BDECFLAGS} WORLD_CCOPTLEVEL (str) Allows to override default compiler optimization level -Ox. Common levels are: 0, 1, 2, 3, g, s, fast. Use of -O3 and -Ofast is strongly discouraged. DEBUG_FLAGS (str) Similar to WORLD_CFLAGS but it will cause STRIP to be set to a blank value, if set. Typically, DEBUG_FLAGS is set to -g for compiling with debug symbols. NO_CPU_CFLAGS (str) Setting this variable will prevent CPU specific compiler flags from being automatically added to CFLAGS during compile time. CXXFLAGS (str) Controls the compiler settings when compiling C++ code. CXXFLAGS is initially set to the value of CFLAGS. If you want to add to the CXXFLAGS value, use "+=" instead of "=". CSTD (str) The default C standard to use when compiling world and kernel C code. Default is gnu11. INSTALL (str) the default install command. To have components compared before doing the install, use INSTALL="install -C" NO_BACKUP (str) Inhibit automatic backup of world binaries as port of "installworld" make(1) target. Default is unset. WORLD_BACKUP (str) defines where system binaries will be backed up for the "backupworld" make(1) target. The default is "/var/backups/world_backup". AUTO_BACKUP (str) defines where system binaries will be backed up automatically as part of the "installworld" make(1) target. The default is "MAKEOBJDIRPREFIX/world_binaries/DESTDIR". LOCAL_DIRS (str) List of directories that should be entered when running make(1) in /usr/src. MAKE_SHELL (str) Controls the shell used internally by make(1) to process the command scripts in makefiles. sh(1), ksh(1), and csh(1) all currently supported. MAKE_SHELL?=sh MODULES_OVERRIDE (str) Set to a list of modules to build instead of all of them. MTREE_FOLLOWS_SYMLINKS (str) Set this to "-L" to cause mtree(8) to follow symlinks. STRIP (str) Set this to the flag to pass to the strip(1) command. If set to a blank value, debug symbols will not be removed. STRIP is automatically set to a blank value if DEBUG_FLAGS is set. WANT_HESIOD (bool) Set this to build hesiod(3) support into libc. NO_NS_CACHING (bool) Set this to disable name caching in the nsswitch subsystem. The generic caching daemon, nscd(8), will not be built either if this option is set. NO_WERROR Set this if you don't want -Werror to be added to CWARNFLAGS or used in the kernel build. STATIC_LOCALES (str) Set to a list of locales to build into statically- linked binaries. Currently supported locales are: BIG5 EUC EUCTW ISO2022 MSKanji UTF8 The following list provides a name and short description for variables that are only used doing a kernel build: BOOT_COMCONSOLE_PORT (str) The port address to use for the console if the boot blocks have been configured to use a serial console instead of the keyboard/video card. BOOT_COMCONSOLE_SPEED (int) The baud rate to use for the console if the boot blocks have been configured to use a serial console instead of the keyboard/video card. COPTFLAGS (str) Controls the compiler optimization settings for kernel and module compiles. KCFLAGS Allows you to add additional compiler flags for kernel and module compiles. But use COPTFLAGS (str) to specify any optimization overrides, as some modules may have to override it to enforce a lower optimization level. KERNCONF (str) Controls which kernel configurations will be built by "${MAKE} buildkernel" and installed by "${MAKE} installkernel". For example, KERNCONF=MINE DEBUG X86_64_GENERIC OTHERMACHINE will build the kernels specified by the config files MINE, DEBUG, X86_64_GENERIC, and OTHERMACHINE, and install the kernel specified by the config file MINE. It defaults to X86_64_GENERIC. NO_CPU_COPTFLAGS (str) Setting this variable will prevent CPU specific compiler flags from being automatically added to COPTFLAGS during compile time. NO_KERNELCLEAN (bool) Set this to skip the clean target when using "${MAKE} buildkernel". NO_KERNELCONFIG (bool) Set this to skip running config(8) during "${MAKE} buildkernel". NO_KERNELDEPEND (bool) Set this to skip running "${MAKE} depend" during "${MAKE} buildkernel". NO_KERNEL_OLD_STRIP (bool) Set this to skip stripping debugging symbols from old kernel and modules (kernel.old, modules.old) during "${MAKE} installkernel". NO_MODULES (bool) Set to not build modules with the kernel. The following list provides a name and short description for variables that are used during the world build: ENABLE_SUID_SSH (bool) Set this to install ssh(1) with the setuid bit turned on. MODULES_WITH_WORLD (bool) Set to build modules with the system instead of the kernel. NO_ALTBINUTILS (bool) Set to not build the alternative (non-default) set of binutils. NO_ALTCOMPILER (bool) Set to not build the designated secondary compiler (GCC 4.7 and others). NO_CVS (bool) Set to not build CVS. NO_GAMES (bool) Set to not build games. NO_GDB (bool) Set to not build gdb(1) NO_INITRD (bool) Set to not build initrd image. NO_LPR (bool) Set to not build lpr(1) and related programs. NO_SHARE (bool) Set to not enter or install to the share subdirectory. NOCLEAN (bool) Set this to disable cleaning during "make buildworld". This should not be set unless you know what you are doing. NOCLEANDIR (bool) Set this to run "${MAKE} clean" instead of "${MAKE} cleandir". NOFSCHG (bool) Set to not install certain components with flag schg. This is useful in a jailed environment. NOMAN (bool) Set to not build manual pages NOMANCOMPRESS (bool) Set to not compress the manual pages. NOPROFILE (bool) Set to avoid compiling profiled libraries. PPP_NOSUID (bool) Set to disable the installation of ppp(8) with the set-user-ID bit on. XAUTH_PATH (str) The path to the xauth program used by OpenSSH client. SENDMAIL_MC (str) The default m4(1) configuration file to use at install time. The value should include the full path to the .mc file, e.g., /etc/mail/myconfig.mc. Use with caution as a make install will overwrite any existing /etc/mail/sendmail.cf. SENDMAIL_SUBMIT_MC (str) The default m4(1) configuration file for mail submission to use at install time. The value should include the full path to the .mc file, e.g., /etc/mail/mysubmit.mc. Use with caution as a make install will overwrite any existing /etc/mail/submit.cf. SENDMAIL_CF_DIR (str) Override the default location for the m4(1) configuration files used to build a .cf file from a .mc file. The default is /usr/local/share/sendmail/cf. SENDMAIL_M4_FLAGS (str) Flags passed to m4(1) when building a .cf file from a .mc file. SENDMAIL_MAP_PERMS (str) Mode to use when generating alias and map database files using /etc/mail/Makefile. The default value is 0640. THREAD_LIB (str) Set to configure the system's default threading library. The default and only available setting is thread_xu. WANT_INSTALLER (bool) Set to build the installer. WANT_NETGRAPH7 (bool) Set to build a newer, experimental netgraph(4) userland. It has to be accompanied by NETGRAPH7* options in the kernel. The following list provides a name and short description for variables that are used when performing various audit builds. FORMAT_AUDIT Enable extra format checking related warnings. WARNS_AUDIT Include skipped or moved warning flags for a given WARNS level in the makefiles.

FILES

/etc/defaults/make.conf /etc/make.conf /usr/src/Makefile /usr/src/Makefile.inc1

SEE ALSO

gcc(1), install(1), make(1), lpd(8)

HISTORY

The make.conf file appeared sometime before FreeBSD 4.0.

AUTHORS

This manual page was written by Mike W. Meyer <mwm@mired.org>. DragonFly 6.3-DEVELOPMENT December 19, 2022 DragonFly 6.3-DEVELOPMENT

Search: Section: