DragonFly On-Line Manual Pages
MAILER.CONF(5) DragonFly File Formats Manual MAILER.CONF(5)
mailer.conf -- configuration file for mailwrapper(8)
The file /etc/mail/mailer.conf contains a series of pairs. The first mem-
ber of each pair is the name of a program invoking mailwrapper(8) which
is typically a symbolic link to /usr/sbin/sendmail. (On a typical sys-
tem, newaliases(1) and mailq(1) would be set up this way.) The second
member of each pair is the name of the program to actually execute when
the first name is invoked. The file may also contain comments, denoted by
a # mark in the first column of any line.
The following is an example of how to set up an mailer.conf for tradi-
tional sendmail invocation behavior.
# Execute the "real" sendmail program, named /usr/libexec/sendmail/sendmail
This example shows how to invoke a sendmail-workalike like Postfix in
place of sendmail.
# Emulate sendmail using postfix
mail(1), mailq(1), newaliases(1), mailwrapper(8), sendmail(8)
mailer.conf appeared in NetBSD 1.4.
Perry E. Metzger <firstname.lastname@example.org>
The entire reason this program exists is a crock. Instead, a command for
how to submit mail should be standardized, and all the "behave differ-
ently if invoked with a different name" behavior of things like mailq(1)
should go away.
DragonFly 3.7 December 16, 1998 DragonFly 3.7