DragonFly On-Line Manual Pages
LPTCONTROL(8) DragonFly System Manager's Manual LPTCONTROL(8)
lptcontrol -- a utility for manipulating the lpt printer driver
lptcontrol -i | -p | -e | -s [-d device]
The lptcontrol utility is used to set either the interrupt-driven,
extended or polling mode of individual lpt(4) devices. When a printer is
switched from a mode to another, this change will only take effect the
next time the device is opened.
Extended mode is anything the parallel port interface can support. For
an ECP/ISA parallel port, it may be FIFO+DMA or ECP.
The following command line options are supported:
-i Turn on interrupt-driven mode.
-p Turn on polled mode.
-e Turn on extended mode.
-s Turn on standard mode, i.e. turn off extended mode.
Set the mode of the printer device specified by device. The
default value for device is /dev/lpt0.
One of -i, -p or -e must be specified.
/dev/lpt? printer devices
/dev/lpctl? printer control devices
/sys/config/X86_64_GENERIC kernel configuration file
The lptcontrol utility first appeared in FreeBSD 1.1.5
Geoffrey M. Rehmet
Sure to be some.
DragonFly 4.3 June 20, 2015 DragonFly 4.3